Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used to have Debian 6, the 64bit version working fine on this system. I'm now trying to install Arch (64bit) and the installer won't boot. Can anybody help me troubleshoot this issue?


My core: http://ark.intel.com/products/43098

Specs: http://pastebin.com/7KVgFch3

share|improve this question

closed as too localized by jasonwryan, Mat, Renan, rahmu, Michael Mrozek Oct 24 '12 at 23:03

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Please describe, what happens if you try to boot. What boot options are used? – rozcietrzewiacz Jul 29 '11 at 12:58
This is rather lacking in description ("the installer won't boot"?), but there's a couple answers that may or may not have fixed the problem, so we might as well leave it open – Michael Mrozek Feb 13 '12 at 20:57
Please describe the problem in more detail for any help. Just stating that installer wont boot does not help anyone in diagnosing the problem. Please state the error messages that you see. – darnir Jul 24 '12 at 13:01
I got a Unknown Paste ID on that page, was it my connection or ..? – warl0ck Oct 22 '12 at 6:54
It's probably because it has expired. This is a very old question that I had asked because my friend was having problems with it, but I think he'll probably have fixed it by now :P – Gabriele Cirulli Oct 22 '12 at 14:57
up vote 0 down vote accepted

Probably it was built for a more typical 64-bit architecture. Atoms are in-order CPUs that lack many features of typical 64-bit processors. Most likely the live system you are trying to boot was built with some gcc optimizations that resulted in instructions not supported by Atom.

You should choose a different live CD/DVD or ask upstream, if one doesn't exist for such CPU.

share|improve this answer
This is my core: ark.intel.com/products/43098 – Gabriele Cirulli Jul 29 '11 at 12:00
Well, the producer is never keen on showing what his product doesn't have, right? If you can boot any other livecd, do so and check /proc/cpuinfo for a complete set of flags. – rozcietrzewiacz Jul 29 '11 at 12:06
It has the lm flag. Here's some more info: pastebin.com/7KVgFch3 – Gabriele Cirulli Jul 29 '11 at 12:49
Yes, I analyzed the cpuinfo already and compared it with CPU flags o my AMD Phenom 2. If that can help, I pasted the flags that are not present in your output here: pastebin.com/gSZCjumg – rozcietrzewiacz Jul 29 '11 at 13:02
The said Arch Linux should work out of the box on this processor system. That is not a problem. – darnir Jul 24 '12 at 12:59

What do you mean with "the installer won't boot"? Do you have a photo/screenshot/log?

I have a Atom 330 and works OK with *BSD and a lot of Linux distros (I haven't tried with Arch).

The best is you open a bug in https://bugs.archlinux.org/ . And try the lastest snapshot of Arch Linux http://mirrors.kernel.org/archlinux/iso/archboot/latest/ .

share|improve this answer

Try installing the 32-bit-version. That should work - even with the Atom.

share|improve this answer
Instruction Set was 64bit, doesn't that means it support 64bit system? – warl0ck Oct 22 '12 at 6:55
@warl0ck The Atom is a strange processor. It is only partly 64-bit - see the accepted answer. I`ve seen other cases with Atoms where 32-bit was working and 64-bit did not. – Nils Oct 22 '12 at 20:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.