Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running a GNU/Linux Debian Lenny with an 2.6.26-2-686 kernel. I installed splashy for a bootsplash an updated grub to version 2.

Now I want splashy to start directly after the user has selected a startoption in grub. At the moment, when the user selects a start option a black screen with bootmessages occurs. I want it so that these messages are displayed in splashy. Or as an alternative, I want to define a background image which is displayed at this phase.

Do you know a solution?

share|improve this question

2 Answers 2

Maybe you should try plymouth, according to its page:

...the boot messages are completely occluded.

share|improve this answer
    
here is a correct link for plymouth cgit.freedesktop.org/plymouth –  Abhishek Jan 14 '11 at 21:00

While plymouth is certainly worth looking into, I use it myself, let's see if we can't actually answer this question for splashy....

You need to make sure that the keyword splash is passed as a kernel argument at boot. This can be added at boot time or in the configuration for your bootloader (i.e. /boot/grub/menu.lst for grub, /etc/lilo.conf for lilo, or /etc/default/grub for grub2).

You may also have to enable the framebuffer on your kernel. To do so, you need to add another parameter to the kernel arguments: vga=791 This argument is most likely unneeded with newer kernels in Squeeze and Sid with KMS enabled.

So the line in /boot/grub/menu.lst might look like this:

kernel  /vmlinuz-2.6.26-2-686 root=/dev/mapper/bootdisk-root00 ro quiet vga=791 splash

Further documentation for splashy can be found here in case you run into other issues:

http://splashy.alioth.debian.org/wiki/faq

share|improve this answer
    
with the whole KMS thing, you realy don't want to enable the framebuffer... –  Stefan Oct 4 '10 at 6:16
    
Right, but I don't think that KMS is enabled in Lenny. In fact your own link says "a kernel image ≥ 2.6.29 (in Sid since 2009-04-04)" while this user has an 2.6.26 kernel. I'll edit above to be a bit more clear. –  andrewsomething Oct 4 '10 at 16:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.