Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I keep getting an address collision warning at boot time, between ACPI and Video Rom. If I add acpi=off to grub.conf the error goes away, but then I have no power management (battery icon, proper shutdown, etc.). Anyone know the cause or a possible solution?

share|improve this question
    
Does anything actually not work or is it just a boot time warning and then everything works? –  Caleb Jul 27 '11 at 19:40
    
@Caleb, just a warning and everything works so far... –  rdrgrtz Jul 27 '11 at 19:52

1 Answer 1

up vote 1 down vote accepted

This can probably be solved in BIOS configuration. If there is a newer BIOS for your machine, you should use it.

Other than that, try booting with pci=noacpi option. If this results in loosing some capabilities you desire, whereas presently everything works fine despite the acpi warning, you might just disable kernel warnings using loglevel=3 boot option. Note however, that this disables all kernel warnings, so if you run into problems in the future, you might need to disable this option for diagnosing those.

share|improve this answer
    
Thanks @jankes, I'll give that a try and report back. –  rdrgrtz Jul 29 '11 at 12:58
    
that did the trick! Thanks! –  rdrgrtz Jul 30 '11 at 1:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.