Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've looked under every search term on google I can think of and can't seem to find anything that works.

I just switched from Windows 7 to Fedora 15 on my PC. I need use of the console port to interact with Cisco switches and other devices. However, I cannot seem to get it to work. I've tried putty, and it says :

Unable to open connection to:
Unable to open serial port

I've tried minicom as well. Both putty and minicom I set up to /dev/ttyS0. I did have it working, once, connected with cat /dev/ttyS0, and it outputted the info from the switch, but when it got to the point where the switch expected input, it looped the input request message dozens of times a second.

I thought it might be a driver issue, but I cannot find any info for getting drivers for serial ports. I'm thinking I probably need to know the adapter model # or something. The port is built into the motherboard though, so I don't know if it has one.

I also tried setserial /dev/ttyS0, but it gives the message:

/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4

Is there a command to get info about the serial port/adapter? Is there something that I am doing wrong that I am not seeing?

share|improve this question
For me, I used the serial/usb converter for my console cable. I had to change the /dev/ttyS0 to /dev/USB0. – user14562 Jan 20 '12 at 20:16

It sounds like you may have the flow control settings wrong - did you play around with Hardware and Software flow control? The would be in the minicom setup.

share|improve this answer
I tried changing both those settings, and it did not help. I did get the console port working with putty, turned out the problem was that my user didn't have access to the ttyS0 interface. I added my user to the appropriate group and that fixed putty. It did not make a difference in Minicom though – AsherMaximum Jul 28 '11 at 17:39
if minicom set to 9600 8N1 ? – Sirex Nov 23 '11 at 11:28

minicom for sure will work. screen /dev/ttyS0 is practical as well.
Just make sure you have read/write permission for for the according tty like Asher said

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.