Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using Arch Linux on an Acer Aspire 5920G and KDE 4.6.5 as WM. All installed packages are up-to-date.

Starting some days ago I got few strange artifacts that spread all over the screen. Interestingly they do not affect any open window at all (neither QT nor GTK or a regular X window). Only the three buttons at the top (maximize, minimize, close) are pixelized but the "content" of any window is intact.

When starting a "good-old X session" instead of KDE there is not artifact at all.

This is a current screenshot. Note that all of the KDE widgets (don't know how they are called) are pixelized while they "eyes" and the whole background image are not at all. Fullscreen apps (games) and Windows work perfect as well. My KDE desktop

Do you have any idea what the problem might be?

This is a part of the X log:

cat /var/log/Xorg.0.log | grep -i nvidia
[    22.675] (II) Module glx: vendor="NVIDIA Corporation"
[    22.708] (II) NVIDIA GLX Module  275.19  Tue Jul 12 18:31:51 PDT 2011
[    22.764] (II) LoadModule: "nvidia"
[    22.797] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    22.910] (II) Module nvidia: vendor="NVIDIA Corporation"
[    22.991] (II) NVIDIA dlloader X Driver  275.19  Tue Jul 12 18:15:26 PDT 2011
[    22.991] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    23.097] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    23.134] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    23.134] (==) NVIDIA(0): RGB weight 888
[    23.134] (==) NVIDIA(0): Default visual is TrueColor
[    23.134] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    23.134] (**) NVIDIA(0): Option "TwinView" "0"
[    23.134] (**) NVIDIA(0): Option "MetaModes" "1280x800 +0+0; nvidia-auto-select +0+0"
[    23.134] (**) NVIDIA(0): Option "TwinViewXineramaInfoOrder" "DFP-0"
[    24.334] (II) NVIDIA(GPU-0): Display (AUO (DFP-0)) does not support NVIDIA 3D Vision
[    24.334] (II) NVIDIA(GPU-0):     stereo.
[    24.354] (II) NVIDIA(0): NVIDIA GPU GeForce 8600M GT (G84) at PCI:1:0:0 (GPU-0)
[    24.354] (--) NVIDIA(0): Memory: 524288 kBytes
[    24.354] (--) NVIDIA(0): VideoBIOS: 60.84.41.00.18
[    24.354] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    24.354] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    24.354] (--) NVIDIA(0): Connected display device(s) on GeForce 8600M GT at PCI:1:0:0
[    24.354] (--) NVIDIA(0):     AUO (DFP-0)
[    24.354] (--) NVIDIA(0): AUO (DFP-0): 330.0 MHz maximum pixel clock
[    24.354] (--) NVIDIA(0): AUO (DFP-0): Internal Dual Link LVDS
[    24.391] (II) NVIDIA(0): Assigned Display Device: DFP-0
[    24.391] (II) NVIDIA(0): Validated modes:
[    24.391] (II) NVIDIA(0):     "1280x800+0+0"
[    24.391] (II) NVIDIA(0):     "nvidia-auto-select+0+0"
[    24.391] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 800
[    25.419] (--) NVIDIA(0): DPI set to (98, 96); computed from "UseEdidDpi" X config
[    25.420] (--) NVIDIA(0):     option
[    25.420] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[    25.433] (II) NVIDIA(0): Setting mode "1280x800+0+0"
[    25.864] (==) NVIDIA(0): Disabling shared memory pixmaps
[    25.864] (==) NVIDIA(0): Backing store disabled
[    25.864] (==) NVIDIA(0): Silken mouse enabled
[    25.867] (==) NVIDIA(0): DPMS enabled
[    25.868] (II) NVIDIA(0): [DRI2] Setup complete
[   402.168] (II) NVIDIA(0): Setting mode "1280x800+0+0"
share|improve this question

1 Answer 1

You are running the closed source driver. Maybe it has a bug.

You could try to switch to an open source driver: Change in Section "Device" the Driver line to Driver "nv" in /etc/X11/xorg.conf.

At least this is where the configuration is stored in my Debian. You can search for a line like this in your log file:

(==) Using config file: "/etc/X11/xorg.conf"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.