Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have my system on dual boot (win7 and RHEL 6).

I have 2 user account on RHEL 6. A normal user and a root user. I put passwords of both accounts same. It was working fine from 5 6 days. Yesterday I installed ntfs-3g to use NTFS drives in RHEL. It worked fine too. Now today's morning when I started my laptop, I login through the normal account, worked fine. Then I accessed NTFS drive, it asked for authentication, I gave root's password but it said that the password is wrong.

I will change the root's password from single user mode. But I just want to know why did this happen? How it changed automatically?

PS: No one else accessed my laptop.

share|improve this question

It probably did not change.

Its possible that its a PolicyKit setting. It's probably asking for your password to use sudo to grant you privileges not for root's password. Even if they are the same it may be trying to do this but you are not in the wheel group and so sudo does not work.

Run visudo as root and enable the group wheel to gain root permissions, then add yourself to that group and try again.

See man 5 sudoers and man gpasswd for the syntax.

share|improve this answer
root's password is not working, I am unable to login via root also. – Chankey Pathak Jul 19 '11 at 6:17
hmm well thats very odd, you may have locked your account, what is the first line of /etc/passwd and /etc/shadow say? – loosecannon Jul 19 '11 at 6:19
root:x:0:0:root:/root:/bin/bash AND root:$6$kan......:15174:0:99999:7::: – Chankey Pathak Jul 19 '11 at 19:22
I was not able to login through root because the password was not working, I changed it from single user mode and then I looked at the passwd and shadow file and then gave you what you wanted. But I think it will not work now. – Chankey Pathak Jul 19 '11 at 19:22
if you reset the root passwd, and it still doesn't work, check you rgroups, and then sudo and Policy Kit settings – loosecannon Jul 19 '11 at 21:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.