Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Based on this suggestion, I want to edit /etc/default/grub to add the line:

GRUB_CMDLINE_LINUX="acpi_osi=Linux"

However, I don't have that file on my system. What should I do?

share|improve this question
    
Do you have the grub package installed? Did you remove the file earlier? –  Gilles Jul 18 '11 at 19:25
    
i just known f15 not use grub2 and it cant config to /etc/default/grub –  asdf Jul 18 '11 at 19:35

3 Answers 3

up vote 6 down vote accepted

Well /etc/default is a Debian/Ubuntu thing, so you're unlikely to find it in Fedora.

You don't need it though - just add the option to the command line for the current entries in grub.conf and Fedora will preserve it when installing new kernels.

share|improve this answer
    
An anonymous user suggests that since Fedora 18, there is now a file /etc/default/grub, similar to the one in Debian/Ubuntu. (Dear anonymous user: this should have been submitted as an answer, not by editing an existing answer.) –  Gilles Jan 8 '13 at 9:38

Maybe you want to change /boot/grub/grub.conf?

share|improve this answer

Fedora 15 uses grub2. You should have /etc/grub.conf symlinked to /boot/grub/menu.lst

share|improve this answer
    
No it doesn't. Fedora 16 will likely use grub2, but Fedora 15 still uses grub 0.97. –  TomH Jul 19 '11 at 12:41
    
grub 0.97 is a prerelease version of grub2 –  hildred Dec 26 '13 at 21:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.