Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am unsuccessfully trying to install some packages in Fedora 15 using yum. Every time I use yum install I get this output:

[ziga@ziga-CQ56 ~]$ sudo yum install yum-fastestmirror
[sudo] password for ziga: 
Loaded plugins: langpacks, presto, refresh-packagekit
Could not retrieve mirrorlist http://ayo.freshrpms.net/fedora/linux/15/mirrors-freshrpms error was
14: HTTP Error 404 - Not Found : http://ayo.freshrpms.net/fedora/linux/15/mirrors-freshrpms
Error: Cannot retrieve repository metadata (repomd.xml) for repository:    freshrpms. Please verify its path and try again
share|improve this question
Have you verified if the url is accessible? – Tshepang Jul 18 '11 at 8:44
up vote 4 down vote accepted

You seem to have the freshrpms repository installed and enabled, but as http://freshrpms.net/ says, since Fedora 10 almost everything has moved to rpmfusion so you probably don't need it anymore and should switch to rpmfusion.

The specific cause of your error is simply that the freshrpms repository doesn't have any content for Fedora 15.

You can probably get rid of the error by uninstalling freshrpms-release:

yum erase freshrpms-release

Though you may also want to then install the rpmfusion repository in it's place - see http://rpmfusion.org/ for details on how to do that.

share|improve this answer
I really did install freshrpms-release and i did both comands that you sugested, but i still get the same error. There must be something else. – 71GA Jul 18 '11 at 8:58
Check in /etc/yum.repos.d and there should be a file that is referencing that repository - find out what package owns that file (with rpm -qf <file>) and remove it, or if no package owns it then just remove the file. – TomH Jul 18 '11 at 9:09
I did it a bit different in /etc/yum.repos.d i found freshrpms.repo file which i opened and changed value of ENABLED to 0. thank you for all the anwsers, we ve solved my problem. – 71GA Jul 18 '11 at 9:13
I comented out some outdated mirrors in /etc/yum.repos.d and i am now fine. – 71GA Jul 22 '11 at 6:38

Given you are on F15, you can use:

yum-config-manager --disable freshrpms

share|improve this answer
Thank you, this is a good to know. – 71GA Jul 22 '11 at 6:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.