Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Suddenly "ifconfig -a" doesn't prints out the "wlan0" on my Fedora14 notebook..WHY? (it worked before..)

Infos:

# dmesg | egrep -i "wireless|wifi|broadcom|bcm4312|10:00.0"
[    0.219841] pci 0000:10:00.0: reg 10: [mem 0xe8000000-0xe8003fff 64bit]
[    0.220074] pci 0000:10:00.0: supports D1 D2
[    1.539203] ata1.00: ACPI cmd c6/00:10:00:00:00:a0 (SET MULTIPLE MODE) succeeded
[    1.543355] ata1.00: ACPI cmd c6/00:10:00:00:00:a0 (SET MULTIPLE MODE) succeeded

# lspci | fgrep -i network
10:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

# rpm -qa | fgrep -i broadcom-wl
broadcom-wl-5.100.82.38-1.fc14.noarch

# lsmod | fgrep -i br
#

# ifconfig -a
eth0 ...
lo ...
# 

# uname -a
Linux localhost.localdomain 2.6.35.13-92.fc14.i686 #1 SMP Sat May 21 17:39:42 UTC 2011 i686 i686 i386 GNU/Linux

# lsb_release -a
LSB Version:    :core-4.0-ia32:core-4.0-noarch
Distributor ID: Fedora
Description:    Fedora release 14 (Laughlin)
Release:    14
Codename:   Laughlin
# 

# vi /var/log/messages:
Jul 16 14:21:40 localhost NetworkManager[1173]: <info> found WiFi radio killswitch rfkill0 (at /sys/devices/platform/hp-wmi/rfkill/rfkill0) (driver hp-wmi)
Jul 16 14:21:40 localhost NetworkManager[1173]: <info> WiFi disabled by radio killswitch; enabled by state file
Jul 16 14:22:12 localhost NetworkManager[1173]: <info> WiFi now enabled by radio killswitch
Jul 16 14:24:05 localhost NetworkManager[1215]: <info> found WiFi radio killswitch rfkill0 (at /sys/devices/platform/hp-wmi/rfkill/rfkill0) (driver hp-wmi)
Jul 16 14:24:05 localhost NetworkManager[1215]: <info> WiFi enabled by radio killswitch; enabled by state file
Jul 16 14:24:32 localhost NetworkManager[1215]: <info> WiFi now disabled by radio killswitch
Jul 16 14:24:37 localhost NetworkManager[1215]: <info> WiFi now enabled by radio killswitch
# 
share|improve this question
    
Does the dmesg results say something about the kernel module for the broadcom drivers? Are the .o files where they should be? Did you had a recent kernel update? (I'm running Fedora 15, I don't keep up with F14 anymore). –  Vitor Jul 16 '11 at 16:03
    
You could also try to reinstall akmod-wl. broadcom-wl is the common package, with kmod-wl and akmod-wl being the driver version in itself. Does it match your kernel version? –  Vitor Jul 16 '11 at 16:06
    
it's funny, because I have two identical laptops with the same up-to-date version of Fedora14, and the problem occurs only on one of them. thx for the tip, i will try –  LanceBaynes Jul 16 '11 at 16:27
    
If one of the laptops is using akmod-wl (the auto updating version of the driver) and the other is running kmod-wl (the version that doesn't update itself) this would explain one working and the other don't after an update. –  Vitor Jul 16 '11 at 16:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.