Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My CPU is 64 bit, I have a PS/2 keyboard and a PS/2 mouse and I have tried Live CDs of Ubuntu, Kubuntu, Fedora, Arch Linux, Wubi installations, 32 and 64 bit (my CPU is 64 bit) and Puppy Linux. I am able to navigate between the menu options when there is one, but when I boot, the keyboard and mouse stop responding. Puppy Linux booted completely, but the keyboard and mouse didn't respond. Besides, pressing NumLock, CapsLock does nothing.

Note that Windows doesn't have this problem.

My keyboard and mouse work flawlessly in Puppy Linux 3.01, but don't in 4.x.

IMPORTANT: I can confirm that keyboard and mouse work in Ubuntu 8.04.4 LTS with linux 2.6.22-14-generic, but DON'T with 2.6.24-29-generic.

share|improve this question
    
So does "keyboard stop working" or "num/caps lock stop working" or the "machine stop working" after you select the boot option? Does it boot, but they keyboard is not responding? –  alex Jul 16 '11 at 11:27
    
@alex I have edited the question; the fact is that the keyboard stops responding after choosing the boot option. –  Juanlu001 Jul 16 '11 at 23:05
    
I have the same problem. I have tried many Linux distributions, and most or all of them fail to acknowledge the PS/2 keyboard after a soft reboot. I have to plug in a USB keyboard or power the system down completely in order to use the keyboard. I have a USB mouse which works just fine through all of this. The latest Linux I have tried in Bodhi, which I downloaded, installed and updated today (2.4.0-32-bit) and it too exhibits the problem. –  BlueMonkMN Aug 16 at 14:02

1 Answer 1

There may be an option in your BIOS something like "USB device emulation" - try toggling that. It may be conflicting with the Linux drivers for some reason. It allows older OSs to see USB keyboards/mice as PS/2 devices.

share|improve this answer
    
You need that option ON if you have a USB keyboard, or you won't be able to interact with grub. –  psusi Jul 16 '11 at 1:02
    
@Aaron I have looked for that option, but my BIOS doesn't appear to have it. Anyway, my keyboard is a PS/2 one, so I don't understand what you meant. In any case, thank you for your answer. –  Juanlu001 Jul 16 '11 at 9:14
1  
@Juanlu001 Ignore psusi's comment if you have a PS/2 keyboard. I have a Dell Dimension 8300 which had a setting called Integrated Devices (LegacySelect Options) and within that setting was an option called USB Emulation. It was initially ON, but I had to turn it OFF so that my PS/2 keyboard would work in Linux after a soft reboot. (Thanks to the assistance of this answer, problem seems solved.) –  BlueMonkMN Aug 16 at 14:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.