Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I modified the /etc/sysconfig/network-scripts/ifcfg-eth0 file to set a static ip for my redhat. Then I tried to use command "service network restart" to make the change stick, however, it became stuck with the last message "Shutting down interface eth0". The network service has really been shut down since I can't connect via the old ip any more(nor the new one).

Why did it fail to restart the network with the new settings?

Also, since the network service on my redhat(remotely) is down, how can I restart it? I need to be able to reconnect to it.

share|improve this question
up vote 1 down vote accepted

It seems that you might have made an error in the new configuration. Usually, if the configuration is correct, and you change your IP, you'd be able to connect after the service restart (To the new IP).

If this is a remote server, your only option is to have someone that has physical access to the server help you out

share|improve this answer
Thanks. I did make an error in the new configuration,i.e., the static ip I assigned is in use with another machine. Is there a way of checking available ip's? – Terry Li Jul 14 '11 at 18:37
ping the ip before assigning it – katriel Jul 15 '11 at 10:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.