Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My TV is a Philips 19PFL4322. It's native resolution is 1440x900 . My laptop's graphics card is a ATI Radeon HD 3650, using the open source radeon driver on X.org server 1.10.

If I connect them via VGA in Linux, or via anything in Windows, it displays correctly at that resolution.

If I connect it via HDMI in Linux, it defaults to a 1024x768 resolution, and GUI tools will only allow me to set it up to 1360x768, all of which look pretty bad on it.

If I force the issue by generating a modeline using cvt 1400 900 and then setting that as the mode using xrandr, I get no output on that monitor.

When connnected via VGA, Linux correctly identifies it as a Philips 19" TV. When connected via HDMI, it misidentifies it as an 18" TV.

How can I get the monitor to display correctly on Linux using HDMI?

EDIT: xrandr output. VGA-0 and HDMI-0 are both my TV, LVDS is my laptop display, 1280x960 which is listed under HDMI-0 is not a valid output for my TV. 1440x900 which isn't listed is a valid output.

Screen 0: minimum 320 x 200, current 2880 x 900, maximum 8192 x 8192
VGA-0 connected 1440x900+1440+0 (normal left inverted right x axis y axis) 410mm x 257mm
   1440x900       59.9*+
   1360x768       59.8  
   1280x720       60.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
LVDS connected 1440x900+0+0 (normal left inverted right x axis y axis) 367mm x 23000mm
   1440x900       60.8*+
   1280x854       59.9  
   1280x800       59.8  
   1280x720       59.9  
   1152x768       59.8  
   1024x768       59.9  
   800x600        59.9  
   848x480        59.7  
   720x480        59.7  
   640x480        59.4  
HDMI-0 connected (normal left inverted right x axis y axis)
   1920x1080i     25.0 +
   1280x960       60.0  
   1360x768       59.8  
   1280x768       59.9  
   1280x720       60.0  
   1024x768       75.1     70.1     60.0  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
share|improve this question
2  
please, add xrandr output –  Hubert Kario Jul 13 '11 at 17:46

2 Answers 2

You could try the closed source ATI driver (that is what I eventually did :-( ) But there I had to increase the Virtual resolution in order to get the big screen working.

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Virtual 3046 1200
                Depth     24
        EndSubSection
EndSection

I wanted to have sync to vblank on my HDMI output and I couldn't find any way to do this with the open source drivers. That's why I eventually went to the tainted ones.

share|improve this answer
    
The performance of fglrx for my card isn't acceptable, sadly. It used to be, but either kernel updates or module updates means it even now lags while scrolling in gedit if I use fglrx. –  Macha Jul 23 '11 at 12:24
1  
I have problems with setting up those drivers as well. You have to make sure that the fglrx.ko kernel module is loaded (you may have to add conflicting open source modules to /etc/modprobe.d/blacklist.conf or delete them). Also you have to make sure that the libGL.so and the .so drivers for Xorg are of the right version (the one from ATI/AMD). One important thing I learned is that you should always install Debian stable, so that you can compile the NVIDIA or ATI modules without having to recompile your kernel. –  whoplisp Jul 23 '11 at 12:37
1  
Yes, EVERY kernel update you need to re-install the ATI driver. On my CentOS machine, that involved re-installing the RPM. The RPM is not smart enough to have a %triggerin. –  Aaron D. Marasco Jul 23 '11 at 13:26

If the modeline defined using the output of cvt 1400 900 does not work, I'm afraid you might not be able to use this mode via HDMI.

What you could try, however, is disabling kernel modesetting (KMS) for the radeon driver either by appending radeon.modeset=0 to your boot options in grub/lilo, or (if radeon is compiled as module) by adding

module_radeon_args="modeset=0"

to your /etc/conf.d/modules. The reason why this might work is that the radeon driver has been reported to cause various problems with kernel modesetting enabled for some new cards.

[EDIT]:

Another good try would be to tell the Xorg server to ignore EDID information, using

Option "IgnoreEDID" "true"

in your xorg.conf, as described here. You'd need a proper modeline for that of course, and that you can obtain after plugging your monitor to the VGA port.

[EDIT2]: Wait a sec, you wrote "cvt 1400 900" - that was a typo, right? You should have used cvt 1440 900 of course.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.