Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a TI usb3410 usb device (it is a TI MSP-FET430UIF programmer), when connected to my debian machine (running squeeze 2.6.32-5-amd64) it shows up in dmesg as

[ 3159.380099] usb 2-1: New USB device found, idVendor=0451, idProduct=f430
[ 3159.380108] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3159.380116] usb 2-1: Product: MSP-FET430UIF JTAG Tool
[ 3159.380121] usb 2-1: Manufacturer: Texas Instruments
[ 3159.380128] usb 2-1: SerialNumber: TUSB3410410886330C60FFD9
[ 3159.380411] usb 2-1: configuration #1 chosen from 1 choice
[ 3159.384312] ti_usb_3410_5052 2-1:1.0: TI USB 3410 1 port adapter converter detected
[ 3159.384336] usb 2-1: firmware: requesting ti_usb-v0451-pf430.fw
[ 3159.391011] usb 2-1: firmware: requesting ti_3410.fw
[ 3159.399203] usb 2-1: ti_download_firmware - firmware not found
[ 3159.399240] ti_usb_3410_5052: probe of 2-1:1.0 failed with error -5

and lsusb as

Bus 002 Device 004: ID 0451:f430 Texas Instruments, Inc. MSP-FET430UIF JTAG Tool
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 05c8:010c Cheng Uei Precision Industry Co., Ltd (Foxlink) 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

However, there is no corresponding device in /dev (it is supposed to show up as /dev/ttyUSB0 etc.)

I have tried creating a udev rule (as described in http://sourceforge.net/apps/mediawiki/mspgcc/index.php?title=Getting_Started_with_Debugging), but that made no difference. In that page (and also http://ubuntuforums.org/showthread.php?t=979460) it is suggested to copy (or link) the firmware to a new location - but on my system, the firmware does not exist in the original location (which makes copying / linking it kinda hard).

I have installed the firmware packages (firmware-linux-nonfree, firmware-linux-free and firmware-linux) but it still does not exist.

/lib/firmware looks like

3com              cxgb3                     hp           mts_gsm.fw
advansys          dabusb                    kaweth       r128
agere_ap_fw.bin   dsp56k                    keyspan_pda  radeon
agere_sta_fw.bin  dvb-fe-xc5000-1.6.114.fw  matrox       tehuti
av7110            dvb-usb-dib0700-1.20.fw   mts_cdma.fw  tigon
cis               e100                      mts_edge.fw

So my question is, what do I have to do to make this usb device work / where can I find the firmware files?

share|improve this question
Have you tried locating the firmware file to make sure it isn't present? sudo updatedb && locate ti_3410.fw – jasonwryan Jul 11 '11 at 18:56
I've just tried it and it returns "/dev/.udev/firmware-missing/ti_3410.fw" which is a zero size file – Ian G Jul 11 '11 at 19:35
Looks like you'll need to build & install the firmware yourself: packages.debian.org/… – jasonwryan Jul 11 '11 at 19:58
The only downside is that I don't know where to find its sourcecode. The impression I got from the above links is that it is included with most distributions. – Ian G Jul 11 '11 at 20:17
There is an rpm here: rpmfind.net/linux/rpm2html/… – jasonwryan Jul 11 '11 at 20:50
up vote 3 down vote accepted

From the suggestion from jasonwryan, I downloaded the rpm from here which is a package containing firmware for OpenSuSE 11.2.

I then extracted the rpm (using rpm2cpio kernel-firmware-20090821-4.1.noarch.rpm |cpio -vid). This creates two directories, lib and usr. The firmware is in the lib directory, so copying to the system was simply sudo cp lib/firmware/ti_* /lib/firmware/. This copies over the two firmware files (ti_3410.fw and ti_5052.fw). Then, after plugging in the device, it showed up in the dev folder as ttyUSB0 (like it should).

I still don't know why these files are not included (or available as a debian package), I can only imagine it is because of debian's licensing requirements.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.