Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a file on an internal server that causes any machine that interacts with it to immediately and irrecoverably freeze. By interaction, I mean just about anything: rm, mv, cp, cat, vi, gedit, less, touch. (ls is fine.) Try any of these commands and the machine will completely halt: the GUI will freeze and all network connectivity goes down. The server hosting the file only goes down if a Windows machine attempts to interact with the file.

The data server is mounted with Lustre and all the servers in question use RHEL 6. This is an internal, well-protected network, and the file was created within the network. There are many, many other files that have been created in a similar fashion that do no exhibit this problem.

What could possibly be going on here? Is there some strange character sequence that causes Lustre or RHEL to flip out? I'm not a sysadmin, and I'm loathe to further interact with the file for fear of bringing down machines in active use for other purposes, but I'd like to know what's going on, how to remove the file if possible, or at least how to prevent creating another similar File of Doom.

share|improve this question
    
Can you download said file using wget or FTP? If so, how big is the file? Once downloaded and saved can the file be edited? –  eyoung100 Oct 27 at 14:22
    
Since ls is fine, please give us the output of ls -l [file] (or even stat [file], if it does not freeze your system). It'll provide us with some file metadata. –  John WH Smith Oct 27 at 14:30
    
The file is a few MB. I've never tried wget or FTP because Lustre is the official network-mounting software. I doubt that FTP or HTTP are enabled. I will try ls -l or stat when I get a safe opportunity to do so. –  patrickvacek Oct 27 at 14:33
1  
Any related logs on the server after the file access and the accessing machine freezed? –  xx4h Oct 27 at 14:38
    
@JohnWHSmith, I tried ls -l and stat and both worked as expected. The permissions are -rw-rw-r--, the filesize is 7594488, there is one link, nothing else was interesting or unexpected. –  patrickvacek Oct 27 at 14:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.