Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm having some trouble with displaying UTF-8 characters correctly on bash. I was trying to extract some zipped files that contained accented characters in their names, and I was getting the invalid multibyte characters error. I created a .bash_profile with this:

export LANG=en_US.UTF-8
export LOCALE=UTF-8

This solved the extraction problem. But the console still doesn't show the accented characters correctly. Konqueror has no problem with the accented characters. What do I have to do?

share|improve this question
2  
What terminal are you running in? Do you mean the Linux console (i.e. outside X)? –  Gilles Jul 6 '11 at 18:12
    
I'm running it under X, with fluxbox, using tilda. –  David McDavidson Jul 8 '11 at 13:15

1 Answer 1

up vote 5 down vote accepted

Gnu Unifont has the widest unicode support. See What fonts are good for unicode glyphs.

Changing the console font (ie., outside X) can be done with the setfont command. Which takes the form: setfont /path/to/font, eg:

setfont /usr/share/kbd/consolefonts/$font

There is more information on the Arch Wiki: https://wiki.archlinux.org/index.php/Fonts#Console_fonts

Once you have selected your preferred font, setting the console font permanently will depend on your distribution. For example, in Ubuntu/Debian, it is:

sudo dpkg-reconfigure console-setup
share|improve this answer
    
It worked, thanks! –  David McDavidson Jul 8 '11 at 13:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.