Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How can I manage to switch on nvidia vdpau decoding on mplayer video player in Ubuntu 11.04? It doesn't work with default options. I've got the proprietary drivers installed:

dpkg -l nvidia-current 
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                                  Version                                               Description
+++-=====================================================-=====================================================-==========================================================================================================================
ii  nvidia-current                                        270.41.06-0ubuntu1                                    NVIDIA binary Xorg driver, kernel module and VDPAU library

If I try it like this:

mplayer -vo vdpau and -vc ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau -ao alsa file.mp4

I get sound but no image window, the prompt showing this:

Playing file.mp4.
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang und
VIDEO:  [H264]  832x468  24bpp  25.000 fps  1402.1 kbps (171.2 kbyte/s)
Clip info:
 major_brand: isom
 minor_version: 512
 compatible_brands: isomiso2avc1mp41
 encoder: Lavf52.64.2
Xlib:  extension "NV-GLX" missing on display ":0.0".
Xlib:  extension "NV-GLX" missing on display ":0.0".
[vdpau] Error when calling vdp_device_create_x11: 1
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
AUDIO: 48000 Hz, 2 ch, s16le, 94.7 kbit/6.17% (ratio: 11841->192000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:  39.2 (39.2) of 5341.1 ( 1:29:01.0)  2.9% 

Any ideas?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You need to use -vo vdpau and -vc ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau, command line options or put them in your ~/mplayer/config.

share|improve this answer
    
edited that I tried it like the following but get no image: mplayer -vo vdpau and -vc ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau -ao alsa file.mp4 –  130490868091234 Jul 3 '11 at 19:58
    
Do you have the proprietary nvidia drivers installed? –  Arrowmaster Jul 4 '11 at 6:01
    
edited I've got them installed –  130490868091234 Jul 4 '11 at 7:03
1  
@avilella: Well this is a Xorg/nvidia issue then and not an mplayer problem. –  Arrowmaster Jul 4 '11 at 19:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.