Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a unique problem with an older Toshiba satellite laptop that happens to be a LegacyFree laptop meaning you can't access the bios via the normal F2, Del, Esc, etc.

I can only select a boot option in the beginning such as HDD, Removeable, CD, Floppy, etc.

The problem I ran into is the bootable USB I created is appearing as a bootable HDD not as a removable device and thus it is booting from the HDD in the computer because I can't change the HDD device priority.

Is there anyway when making the bootable USB to make it appear as a USB instead of HDD?

I've been using unetbootin and LinuxLive to create these bootable USBs.

NOTE: I am aware you can access LegacyFree Bios is through a program called Tsetup or HwSetup through windowsXP problem is that The laptop doesn't have any OS currently installed.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Many BIOSes treat USB drives as “HDD” if they have a partition table and “Removable” if they don't. This isn't something you can change short of flashing a different BIOS altogether (rarely an option).

Most BIOSes let you choose the order of available “HDD” devices in a separate screen. Some let you press a key at boot time to select the HDD. If these options are not available to you, make a non-partitioned USB stick.

Create a filesystem directly on the USB stick, not on a partition:

mkfs.vfat /dev/sdb

(Replace /dev/sdb by the right drive. Be sure to get this right since it'll destroy the data on that drive.) Then follow the instructions to make that live/installation USB stick. If you already have a stick image with a partition table, copy all but the first sector of it onto the stick:

tail -c +513 <whole-disk-image-file >/dev/sdb

then re-run the bootloader installation on the stick (e.g. syslinux /dev/sdb if the bootloader is Syslinux).

share|improve this answer
    
Ahh that would definitely explain it. I had used windows diskpart utility and made a partition and set it to active. Before doing that it appeared as removable device. Thanks again! –  Grant Jul 7 '11 at 0:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.