Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After my upgrade to Debian 6 (Squeeze), the keyboard layout used to enter the password of encrypted filesystem has been changed. How can I revert it back to previous one?

My understanding is that, before the encrypted filesystem gets unlocked, the only active partition is /boot, therefore such a setting should be there somewhere. However, after extensive Internet searching and grepping /boot, I've not been able to find it.

I've also tried to reconfigure the keyboard layout used by the console, running:

dpkg-reconfigure keyboard-configuration

...and:

dpkg-reconfigure console-data

...with no effect.

share|improve this question

migrated from stackoverflow.com Jul 1 '11 at 19:49

This question came from our site for professional and enthusiast programmers.

1  
If you have an encrypted root filesystem, you'll have to get setting the keymap to be part of the initramfs. I don't think thats done by default. Off-topic here, though; belongs on unix I suspect. –  derobert Jul 1 '11 at 18:58
    
Thanks Caleb. That was it. I did this link, and it worked. –  Elena Jul 2 '11 at 23:25
    
@Elna: Please add an short answer below with a summary of how you fixed the problem and after the timeout mark it as "accepted". That is how SE sites keep track of what answers are solved. –  Caleb Jul 6 '11 at 19:55

1 Answer 1

You need to customize your initramfs. Take a look at the update-initramfs manpage as one possible starting point.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.