Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a problem printing from Libre Office (3.4.0 build 12).

  • OS: Arch Linux, CUPS version 1.4.6
  • Printer:
  • Description: Brother HL-2040
  • Location: Home
  • Driver: Brother HL-2040 Foomatic/hl1250 (recommended) (grayscale, 2-sided printing)
  • Connection: socket://192.168.178.1:9100
  • Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

When printing Slides for Libre Office Impress with "Landscape" orientation, they are printed with "Portrait" orientation, as a result, right part of the slides are missed.

In Libre office:

File->Printer Settings -> Properties -> Pager:

  • Paper Size: A4
  • Orientation: Lanscape

File-> Printer Settings -> Properties -> Device:

  • Printer Language Type : PDF

If I change Printer Language Type to PostScript everything work OK.

The problem is that Libre Office does not store this setting.

Question: How can I permanently change the Printer Language Type setting to Postscript?

share|improve this question
    
Does this setting get saved per document? Sometimes that happens to settings in LibreOffice and you have to jump through hoops to make it the default for new documents. –  Caleb Jul 1 '11 at 13:40
    
Now you have an answer here, delete your question on Superuser: superuser.com/questions/304667/… - I don't think cross-posting is accepted practice... –  jasonwryan Jul 1 '11 at 19:24
    
spadmin and printer settings within LibreOffice both don't change the settings permanently here (LO 3.6.2.2, 64 bit, Kubuntu 12.10) –  user30359 Jan 16 '13 at 5:58

4 Answers 4

Use spadmin, which is a utility that comes with LibreOffice.

Log in as root!

Find the directory that contains all the LibreOffice executables. On my openSUSE 11.4 installation, it is /usr/lib64/libreoffice/program.

You can find it on your system by finding the soffice executable.

$ which soffice
/usr/bin/soffice

$ cd /usr/bin

If it is the executable, you will find spadmin there, too. But it is probably a link.

$ ls -l soffice
soffice -> ../lib64/libreoffice/program/soffice

This means that it is a link, so cd to the path that the link points to.

$ cd ../lib64/libreoffice/program

Start spadmin

$ ./spadmin

The application will pop up and you can set the defaults there. These will stick. Be careful to check the default paper sizes too. This utility seem to want to move them.

share|improve this answer
    
This doesn't work for me. The "printer language" setting doe not stick (tried spadmin as root and as user), it just reverts to "PDF". The setting does not appear on cups admin web interface "printer defaults". –  molecular Dec 5 '12 at 9:30

I would look into the CUPS settings first and make sure the printer is setup with the right defaults so that when LibreOffice looks at it it recognizes the printers preferred format as PostScript.

share|improve this answer
    
Any Ideas where to look? I tried to use web interface, but do not found anything related to this settings. –  Anton Prokofiev Jul 1 '11 at 13:55
    
This setting ("printer language") does not appear in cups web interface default printer options. –  molecular Dec 5 '12 at 9:31

I have the same problem, but it seems that this default option is not configurable in ooo/libreoffice. From their bugzilla:

It could also be done in a way that it is run-time configurable whether PostScript or PDF gets generated with default set at build time.

share|improve this answer

Just like Bill say, use spadmin or LibreOffice 3.4 Printer Administration (on menu point to Office section) but no need to log in as root.

Open "Printer Administration" and look for your printer properties. On the device tab change the "Printer Language Type" and choose "PostScript Level 1".

Open LibreOffice Writer and go to File -> Printer Settings and look for your default printer properties, you should now find that the default printer language isn't PDF but PostScript Level 1.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.