Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I was using Emacs, and typed Control+Alt+D in order to run Emacs' "down-list" command. I was dismayed to see, however, that I was instantly logged out; I assume this is some Gnome keyboard shortcut.

I looked under System/Preferences/Keyboard shortcuts, and saw nothing pertinent; I then ran gconf-editor and searched through it for , and still saw nothing pertinent.

So ... how to I disable this feature?

share|improve this question
1  
May be it's that all your windows were minimized (hidden?) That appears to be 'show desktop' shotcut, not 'log me out'. You might try pressing the same combination again to get your windows back. –  alex Jun 29 '11 at 18:19
    
er, pressing the same combination again does nothing, because at that point I'm looking at the "please log in" screen. In any case, I've mapped "show desktop" to M-d (i.e., I hold the Windows key down and then press d), and it works fine. –  offby1 Jul 1 '11 at 17:17
    
Maybe that's a shortcut to switch user then? –  alex Jul 1 '11 at 17:38
    
Ctrl+D is the end-of-file character in most Unix-land. Typically shells will respond to this by exiting. So if your Ctrl+Alt+D gets mapped to Ctrl+D along the line, having the shell exit would be explainable. In Bash, you can disable this by setting the IGNOREEOF built-in variable. –  Stabledog Apr 3 '13 at 20:49
    
@Stabledog: I'm familiar with the behavior of Ctrl+D in shells; this is different. –  offby1 Apr 4 '13 at 0:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.