Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After a new update, there is no sound by default in my Debian Squeeze box until running alsactl init, but whenever rebooting the computer I have to run the command again to gain sound.

How can I solve this problem?

share|improve this question

closed as off-topic by Braiam, slm Oct 23 '14 at 15:19

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Braiam, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

I have tried `alsactl store'. –  xando Jun 28 '11 at 17:42
Are you sure that the alsa init.d script is starting? –  Let_Me_Be Jun 28 '11 at 18:10
Hi Let_Me_Be, there's only a file /etc/init.d/alsa-utils. –  xando Jun 28 '11 at 20:25
Yes, that should be the alsa init script name in Debian based systems. –  Let_Me_Be Jun 28 '11 at 21:11
Does it help if you run /etc/init.d/alsa-utils restart once (after sound works)? Do you have a file /var/lib/alsa/asound.state? When you have no sound, do applications that should produce sound emit error messages, or do you just hear nothing? –  Gilles Jun 28 '11 at 22:53

1 Answer 1

sudo alsactl store

to save mixer settings manually, it should work afterwards

share|improve this answer
Sounds like he already tried it –  Michael Mrozek Feb 15 '12 at 15:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.