Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using Fedora 13 and my VLC media player is showing this problem for the past one week. How do i rectify this error.


Summary:

SELinux is preventing /usr/bin/vlc from loading /usr/lib/vlc/plugins/codec/libdmo_plugin.so which requires text relocation.

Detailed Description:

The vlc application attempted to load /usr/lib/vlc/plugins/codec/libdmo_plugin.so which requires text relocation. This is a potential security problem. Most libraries do not need this permission. Libraries are sometimes coded incorrectly and request this permission. The SELinux Memory Protection Tests (http://people.redhat.com/drepper/selinux-mem.html) web page explains how to remove this requirement. You can configure SELinux temporarily to allow /usr/lib/vlc/plugins/codec/libdmo_plugin.so to use relocation as a workaround, until the library is fixed. Please file a bug report.

Allowing Access:

If you trust /usr/lib/vlc/plugins/codec/libdmo_plugin.so to run correctly, you can change the file context to textrel_shlib_t. "chcon -t textrel_shlib_t '/usr/lib/vlc/plugins/codec/libdmo_plugin.so'" You must also change the default file context files on the system in order to preserve them even on a full relabel. "semanage fcontext -a -t textrel_shlib_t '/usr/lib/vlc/plugins/codec/libdmo_plugin.so'"

Fix Command:

chcon -t textrel_shlib_t '/usr/lib/vlc/plugins/codec/libdmo_plugin.so'

Additional Information:

Source Context unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1 023 Target Context system_u:object_r:lib_t:s0 Target Objects /usr/lib/vlc/plugins/codec/libdmo_plugin.so [ file ] Source vlc Source Path /usr/bin/vlc Port Host (removed) Source RPM Packages vlc-core-1.1.3-1.fc13 Target RPM Packages vlc-core-1.1.3-1.fc13 Policy RPM selinux-policy-3.7.19-51.fc13 Selinux Enabled True Policy Type targeted Enforcing Mode Enforcing Plugin Name allow_execmod Host Name (removed) Platform Linux (removed) 2.6.34.6-47.fc13.i686.PAE #1 SMP Fri Aug 27 09:29:49 UTC 2010 i686 i686 Alert Count 3 First Seen Sat 04 Sep 2010 08:26:05 PM IST Last Seen Sat 04 Sep 2010 08:35:40 PM IST Local ID 48840a90-fea4-403b-95a3-6cadc80b1a0a Line Numbers

Raw Audit Messages

node=(removed) type=AVC msg=audit(1283612740.262:117): avc: denied { execmod } for pid=9594 comm="vlc" path="/usr/lib/vlc/plugins/codec/libdmo_plugin.so" dev=sda2 ino=789070 scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lib_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1283612740.262:117): arch=40000003 syscall=125 success=no exit=-13 a0=4439000 a1=1e000 a2=5 a3=bfbe2480 items=0 ppid=1 pid=9594 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="vlc" exe="/usr/bin/vlc" subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)


Update Well, i tried that now in terminal and nothing seems to happen.

[chandru.math@chandru ~]$ chcon -t textrel_shlib_t '/usr/lib/vlc/plugins/codec/libdmo_plugin.so

It stops like this!

share|improve this question
    
Hello @Chandru1 you will need to run it with sudo, sudo chcon -t textrel_shlib_t '/usr/lib/vlc/plugins/codec/libdmo_plugin.so' also make sure you have the single ' at the end of the line. –  Steve Burdine Sep 4 '10 at 16:05
    
if I we're u, I would disable and remove SELinux, ofcourse it is not the answer to your problem, but it will solve your problem, just for your consideration. –  uray Sep 5 '10 at 2:13

1 Answer 1

up vote 2 down vote accepted

Did you run the fix command in the summary you posted?

sudo chcon -t textrel_shlib_t '/usr/lib/vlc/plugins/codec/libdmo_plugin.so'
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.