Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have this strange issue. scp is hard locking my server.

I have tried memcheck, tried downloading big files using wget, tried speed test in openssl and everything works just fine, yet every time I try to copy something (from or to the machine) using scp, it hard locks the machine.

Not even sysrq magic key combos work.

What could be the cause of this? I have no idea where to look.

Edit: I just managed to crash the system using nfs server.

share|improve this question
Running strace scp ...? Un-installing/re-installing completely your ssh suite? – forcefsck Jun 25 '11 at 19:46
@forcefsck nothing helpful there. I just managed to crash the system using nfs server, so it isn't just scp. But scp works very reliable. – Let_Me_Be Jun 25 '11 at 20:21
up vote 1 down vote accepted

I suspect there's an obscure bug in either your Ethernet driver, or your Ethernet device's firmware or hardware. Can you trigger the bug by scp'ing to localhost? If not, try replacing the components:

  • upgrade your network device's firmware, in case the firmware is at fault;
  • try another network device (e.g. plug in a PCI Ethernet board), in case the firmware or hardware is at fault;
  • try a different driver version, in case the driver is at fault or the other version manages to work around a firmware bug.
share|improve this answer
The weird thing is that the machine worked just fine, until I replaced all the disks with new ones. – Let_Me_Be Jun 25 '11 at 20:40
@Let_Me_Be Hmm. Is your power supply marginal? Mind you, it could still be a fault in the network hardware, for example it might be sending stuff on the PCI bus with bad timing, but only rarely, so you'd only see it if there was disk activity at the same time, which in practice depends on the disks' response time. Or something like that. I doubt you'll be able to locate the fault other than by replacing components (hardware or software) in turn. – Gilles Jun 25 '11 at 21:06
Weird thing I noticed is that when using nfs, the machine crashes when the client is closing the file. It could be just weird buffers at play, but it is consistent. Power supply should be sufficient (525W). – Let_Me_Be Jun 25 '11 at 21:11
It was the network card driver. Realtek cards have a bugged kernel driver that crashes the machine when stressed. The driver from Realtek works fine. – Let_Me_Be Jun 27 '11 at 12:46

There was a similar issue in a thread on the Arch boards recently.

The poster fixed it by resetting the BIOS.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.