Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using Fedora 13 and its working great. The only problem which I am facing is that the networking gets automatically disabled if I put my system on the "SUSPEND" mode for > 30mins. I am unable to enable it even after right clicking. Then I have to restart my system, to get the internet working. Can anyone show me how to rectify this!

share|improve this question
    
So stop suspending it and use hibernate or shut down? Fedora 13 is just out recently and still ironing the kinks out, we sleep in the bed we lay and picking a distribution is no different. –  Chris Sep 4 '10 at 12:07
add comment

1 Answer

up vote 4 down vote accepted

I have been having the same issue with Fedora 13. It has been hit or miss when network does not work after suspend for me. Here is what I run in a terminal to restart the network connection.

sudo /etc/init.d/NetworkManager restart

Update: this is a work around from this post at Fedora forums

In a text editor open

sudo vi  /usr/lib/pm-utils/sleep.d/55NetworkManager

on each line that says (I had two entries)

dbus_send --system \

add

--print-reply

so it looks like this:

dbus_send --system --print-reply \

After the edit I tried suspend everything resumed fine, but; I have not given it any heavy testing.

share|improve this answer
    
I've been having the same issues and this is how I've been getting around it. I saved it as a script so I can quickly run it from gnome-do after I wake back up. –  David Barry Sep 4 '10 at 4:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.