Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I open files by double-clicking a file with mouse I always get one additional "Unsaved Document X".. which is very annoying, because I have to close tham all, and click "Close without save" every time... This happens in dolphin, nautilus and krusader (those are the ones where I tried it, so I gues it's not because of a file manager).

When I try opening a file from terminal using "gedit filename" the problem is not there. It also does not happen if I open files from within gedit.

Any hints on how to fix this?

This started happening I think somewhere around the time when gnome3 came into Arch official repos. (I use up-to-date Arch and KDE4.6)

share|improve this question
    
Are you using KDE or Gnome? KDE usually defaults to single clicks while Gnome uses double clicks. –  wojox Jun 19 '11 at 14:22
1  
I wrote in my post that I use KDE4.6 =) and thanks, but nope - it's not about single/double clicks.. I turned single-click off a long time ago. –  pootzko Jun 19 '11 at 18:56
    
@wojox: OP already stated he's using KDE 4.6. –  Caleb Jun 19 '11 at 19:02

3 Answers 3

up vote 2 down vote accepted

Felrood from Arch Linux forums provided a solution and I would like to share it here and close this question.

Gedit seems to display data from stdin in a new "Unsaved document". For example:

echo "foobar" | gedit

What can be done is this:

right click the Kmenu button -> edit applications -> find gedit there (for me that is "utilities") -> put "gedit $1 < /dev/null" in gedits command field -> save

For me that solved the problem no matter whether I use krusader, dolphin, alt+f2 or something else..

share|improve this answer
    
That has been bugging me for a while, thanks / upvote :) –  Ing Mar 13 '13 at 17:15

I am not sure about this but its worth a try.

Suppose you want to open file123

Use the terminal to cd into the folder that contains this file.

Then do ls -a

If there exists a file named .file123, remove it i.e sudo rm .file123

Now try opening file123, the problem should not be there.

share|improve this answer

Try sudo apt-get purge gedit the search in Synaptic (sudo apt-get install Synaptic if you don't have it) for you gedit package then go to menu Package -> Force version and choose the version you think is stable.

share|improve this answer
    
Did you read my question to the end? I wrote I use Arch Linux so - no apt-get/synaptics for me.. ;) –  pootzko Oct 18 '11 at 14:43
    
Maybe you can try dpkg -P to purge and dpkg --force-downgrade gedit to try go back to the older version or go to Arch Linux repository, download the archive gedit you think is stable gedit in ArchLinux and install it using dpkg -i --force-all Name_of_downloaded_file –  GarouDan Oct 18 '11 at 15:04
    
I wish I could use that yeah, but Arch does not use .deb packages at all nor is dpkg in Arch repos.. Thanks for trying though. :) –  pootzko Oct 19 '11 at 7:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.