Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get meld 3.11 to work on ubuntu 14.04

I tried following the method below"

cd ~ 
git clone https://git.gnome.org/browse/meld 
cd meld  
sudo ln -s ~/meld/bin/meld /usr/bin/meld

But when i run meld in the terminal i get the following error

Traceback (most recent call last):
  File "/usr/bin/meld", line 223, in <module>
  File "/usr/bin/meld", line 197, in setup_settings
  File "/usr/lib/python2.7/subprocess.py", line 522, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
   OSError: [Errno 2] No such file or directory

I am not sure if its dependencies issue or python path problem.

share|improve this question
Check the README for directions on installing. It's located in the meld folder... It has a setup.py. It also has nothing to do with Ubuntu. – RobotHumans Aug 9 '14 at 10:31
Try doing a backport. 3.11 is available packaged for debian experimental, at least. See unix.stackexchange.com/q/112157/4671. If you want more information about this, please say so. – Faheem Mitha Aug 9 '14 at 10:45
up vote 11 down vote accepted
#Make a clean working directory
mkdir -p work/crap
#Get in to that directory
cd work/crap
#Clone git head
git clone https://git.gnome.org/browse/meld
#Get in to that project directory
cd meld
#Install dependencies
sudo apt-get install intltool itstool gir1.2-gtksource-3.0 libxml2-utils
#Install meld
sudo python setup.py install

If you wanted to work on the code itself without re-installing, I typically do that by installing in a venv and opening the installed to folder in the venv in an IDE.

Result of running meld in a terminal after those steps:

enter image description here

Note that the current version of meld requires GTK+ 3.14, which is not available on Ubuntu 14.04 (Meld requires GTK+ 3.14 or higher. error). So for Ubuntu 14.04, you need to checkout the last version that does not need GTK+ 3.14. That is the meld 3.14.* branch (currently 3.14.3), so checkout the branch using git checkout meld-3-14.

share|improve this answer
i am going to try your method now. – Ibn Saeed Aug 9 '14 at 16:03
I got the following after doing the final step. ..... unable to execute 'glib-compile-schemas': No such file or directory. ...... – Ibn Saeed Aug 9 '14 at 16:10
either i have a dangling dependency from my current install that i can't see, or you have broken packages or you're using a broken distro or custom themes that break stuff. in any case , it works here – RobotHumans Aug 9 '14 at 16:37
if you asked what you think are ubuntu related questions on AU or searched there, you would find this: askubuntu.com/questions/161739/… which points to this libglib2.0-bin as the dangling dependency, but i digress... – RobotHumans Aug 9 '14 at 16:43
I had to install the dependancy libglib2.0-dev and libgee-dev and python-cairo for it to work. – Ibn Saeed Sep 17 '14 at 9:27

I found meld 3.12 available in ubuntu 14.10 repository.

deb package installation works even under 14.04


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.