Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Basically if I reboot the machine, I can vnc into it (using ultra vnc) but I can only do it once. It seems that the vnc daemon stops working after the first remote desktop session is closed. I have to reboot the machine to VNC into it…

I've ran apt-get update and apt-get upgrade, the system is up to date… I can't figure out why it will only work once.

share|improve this question
    
how are you calling the vnc server, what cli options on the client and server? –  Mike Pennington Jun 13 '11 at 17:26
    
I usually enable it from the GUI System -> Preferences -> Remote Desktop I have like 20 other machines set up the same way and they have no problems –  kLeos Jun 13 '11 at 18:54
add comment

2 Answers 2

Consider adding -alwaysshared to allow shared connections. There's also another argument that turns off the 'close on disconnect' behavior you are seeing.
Please check the manual page for the vnc server you are running. I'd give you the argument myself, but the server(s) I have available to check on do not document this argument as they do not default to this behavior.

share|improve this answer
    
I'm using the default VNC that comes with debian it's called Vino I usually run these commands to set it up gconftool-2 -s -t bool /desktop/gnome/remote_access/enabled true gconftool-2 --type bool --set /desktop/gnome/remote_access/prompt_enabled 0 gconftool-2 --type list --list-type string --set /desktop/gnome/remote_access/authentication_methods '[vnc]' gconftool-2 --type string --set /desktop/gnome/remote_access/vnc_password $(echo -n 'mypassword'|base64) –  kLeos Jun 13 '11 at 18:46
    
Ick. You might consider running something like xtightvnc instead - a bit of a pain, but probably more flexible in the end. As well, it doesn't use gconf which is a selling point in and of itself! –  draeath Jun 13 '11 at 19:08
    
Ehh, I'm only having a problem with this one machine. I have 20 more or so running the exact same configuration and they are all working fine... I'll try getting an image from another one and flashing it onto this one. Thanks –  kLeos Jun 13 '11 at 19:16
1  
Seen some exit vnc-on-disconnect too, like for x11vnc, that has a persistence option: karlrunge.com/x11vnc/x11vnc_opts.html#opt-forever. Might be that you have something in a rather hidden place like under /etc/default/? –  hasienda Jan 22 '12 at 13:05
add comment

Any vnc server supports share desktop feature. Please check the man of your vnc server.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.