Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It's been almost 15 days since I installed Fedora 15 on my laptop. And since day 1, Twitter seems to be having some issue opening up. Whenever I try to load twitter.com, it loads an "Aw Snap" page.

From the answers here, I did sudo setenforce 0 and Twitter started working fine. But turning off SELinux doesn't seem to be a good thing to me. I tried disabling all extensions and removing all the apps from Google Chrome. Still the problem persists.

Can someone please provide some solution to this irritating problem?

share|improve this question
You should file a bug report on Google Chrome. – alex Jun 13 '11 at 16:46
up vote 5 down vote accepted

There is a better way to fix your problem. The bug is that chrome's configuration files are created with the wrong label on it. To fix that, just run :

$ restorecon -R ~/.config

And you are done.

share|improve this answer

There are better options to simply disabling SELinux. You can set SELinux to use permissive mode so that it complains instead of blocking the execution of google chrome. Better yet, you can create a new local policy that allows google-chrome to run under SELinux, Here are some links to get you started:




Read the last link for the procedure, but do document yourself before jumping in, a fair understanding og what you are doing will reduce unnecessary frustration.

share|improve this answer
Thanks for the links. I shall try that out tomorrow morning. – Dharmit Jun 13 '11 at 18:15
2 questions before I start reading those massive articles. 1) Google chrome's working fine but it's twitter that's not working fine in Google chrome. hope the docs apply to me in that case. 2) Docs are for F13. I am using F15. F15 docs don't have SELinux article like F13 has. – Dharmit Jun 14 '11 at 2:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.