Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using a Red Hat 4 Enterprise Linux. But, when I upgrade the kernel, an error occurred. And after, when computer is booting with new kernel (red hat enterprıse 2.6.9-100.el), I receive the following the error.

mkrootdev: label /1 not found
mount: error 2 mountıng ext 3
mount: error 2 mountıng none
switchroot : mount failed :22
umount /initrd/dev failed :2
kernel panic -not syncing :Attemped to kill init!

After, when I try to boot the system with old kernel (red hat enterprıse 2.6.9-42.el), the system successfully booted.

My question is; when I rebooted the system, it attempt to boot with new kernel every time and so I have got to choose the old kernel with hand all the time. How to get rid from this problem?How can I uninstall the new kernel without problem? or How can I use the new kernel without problem?

something like this grub.conf;

"default=0
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux ES (2.6.9-100.ELsmp)
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.9-100.ELsmp ro root=LABEL=/1 rhgb quiet
    initrd /boot/initrd-2.6.9-100.ELsmp.img
title Red Hat Enterprise Linux ES (2.6.9-100.EL)
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.9-100.EL ro root=LABEL=/1 rhgb quiet
    initrd /boot/initrd-2.6.9-100.EL.img
title Red Hat Enterprise Linux ES (2.6.9-42.ELsmp)
    root (hd0,0)"
share|improve this question
1  
I'm curious to know what the root= option is set to for the working kernel. Is it also root=LABEL=/1 ? –  Mark Drago Jun 13 '11 at 14:53
    
Please state clearly the working and non-working kernels, and the grub config for each. –  Faheem Mitha Jun 13 '11 at 15:16
add comment

1 Answer

up vote 1 down vote accepted

Get your machine running with the good kernel and then edit /etc/grub.conf so it defauts to your good kernel , check the line in grub which says "default=0". Changing that will fix your manual intervention boot issue. In your case default would need to be "default=3" to boot your old good smp kernel

Then look at removing your problem kernel with rpm -e , may be do a test (rpm -e --dry-run

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.