Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Installed Ubuntu 14.04 LTS from a USB stick to a partition on my Dell Inspiron N5010. I login to Ubuntu and opbserve the Wifi appears to connect to teh wi-fi network, but Firefox cannot connect to any site.

I run the command

lspci -vvnn | grep 14e4

and see that I have a broadcom BCM4313... [14e4:4727] (rev 01)

ifconfig and lshw appear to show the device working and connected, but again no Internet. I tried to reinstall driver from uui/pool//restricted/b/bcmwl without success.

I have observed several people having issues with this configuration and I have tried some resolutions, without success. The device works under Windows 7.

tony@ahsoka:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 78:2b:cb:d1:88:26
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:163 errors:0 dropped:0 overruns:0 frame:0
TX packets:163 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11761 (11.7 KB) TX bytes:11761 (11.7 KB)

wlan0 Link encap:Ethernet HWaddr 68:a3:c4:16:e3:1f
inet6 addr: fe80::6aa3:c4ff:fe16:e31f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:21 errors:0 dropped:0 overruns:0 frame:31620
TX packets:190 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3439 (3.4 KB) TX bytes:36220 (36.2 KB)
Interrupt:17

tony@ahsoka:~$ iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11abg ESSID:"ips-guest"
Mode:Managed Frequency:2.437 GHz Access Point: 10:BD:18:1B:3C:72
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
share|improve this question
1  
Show the output of ifconfig and iwconfig –  Braiam Aug 5 at 16:22
    
I will try to post the output here. It is kind of multi-step process without internet on the OS/machine. –  iowatiger08 Aug 7 at 16:00
    
Your wlan0 interface doesn't have an IPv4 address, which means that either DHCP on your computer isn't active and listening, that the router isn't giving out DHCP leases, or that you aren't properly connected. I'm personally going with case 3, since there's no information about the strength of the wireless signal in iwconfig. –  saiarcot895 Aug 7 at 20:31

1 Answer 1

up vote 1 down vote accepted

Firstly, perform the following steps:-

  1. Trying pinging to your router from your laptop. Replace 192.168.1.1 with your local router address.

    $ ping 192.168.1.1

  2. Trying pinging to the internet if the above step works

    $ ping 8.8.8.8

If you are able to ping to your router and not to your internet the problem is between wifi and router. If you are able to ping to your router and the internet then the problem is the way Firefox has been configured. Try installing Google Chrome and use it.

If you are not able to connect to the internet, then there might be a problem with your driver.

To rectify that you will have to install b43-fwcutter package from ubuntu or launchpad repositories. If you have another way to connect to internet while still from Ubuntu, the following is the easiest way:

$ sudo apt-get install firmware-b43-installer

If internet is not available do the following:-

  1. From another computer download b43 firmware from the link below and copy it to your Desktop:

    http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2

  2. In the terminal:

    $ cd '/home/uname -r ~/Desktop/broadcom-wl-4.80.53.0 2/kmod'

    $ sudo b43-fwcutter -w /lib/firmware/uname -r ~/Desktop/wl_apsta.o

  3. Wait until extracted, then:

    $ sudo modprobe b43

This should work.

If this does not work follow the instructions here:

$ wget http://bues.ch/b43/fwcutter/b43-fwcutter-018.tar.bz2 
$ tar xjf b43-fwcutter-018.tar.bz2
$ cd b43-fwcutter-018
$ make
$ sudo make install
$ cd ..
$ export FIRMWARE_INSTALL_DIR="/lib/firmware"
$ wget http://www.lwfinger.com/b43-firmware/broadcom-wl-5.100.138.tar.bz2
$ tar xjf broadcom-wl-5.100.138.tar.bz2
$ sudo b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" broadcom-wl-5.100.138/linux/wl_apsta.o

If this does not work, then go to some a nearby Linux Users Group and have your laptop looked at by your local Linux Guru.

share|improve this answer
    
ping the router was reachable, but ping outside e.g. 8.8.8.8 was unreachable. I am even required to enter credentials for the wifi network. I followed the instructions here, except i downloaded the packages and copied them over via USB drive and extracted the tar in the Desktop, but this did not improve the connection. –  iowatiger08 Aug 7 at 15:48
    
It seems you have some custom configuration with respect to your router and PC for it to work properly. Can you connect to the Internet through any other device, say smartphone or tablet without making any configuration changes? The fact that you can ping to your router and not the internet says that you are infact able to connect to wifi with your router. Go to your browser and enter 192.168.1.1 and see if you are able to access the router control panel. –  ksinkar Aug 8 at 5:34
    
I may have been testing with the wrong wifi network. I am now working correctly. thank you for your help –  iowatiger08 Aug 8 at 19:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.