Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Let's say you have a screensaver running. When you move your mouse or hit any key on keyboard, the screensaver will be stopped.

The problem is that with modern, laser based mice, a slight vibration of desktop, causes mouse to send signal as "moved". So I would like to stop the screensaver only with keyboard -- I could have the screensaver running and move the mouse with no effect on it (clicking could be ignored or not, I don't care).

So -- is there a way to do it? If yes -- how?

openSUSE 11.4, KDE3 (yes, 3 -- the best DM so far).

share|improve this question
Alternative I would prefer to see would be a 'deadzone' setting for mouse movement so that minor movement is ignored but large movement isn't. – Arrowmaster Jun 11 '11 at 23:02
Yes, this one too would be a solution. – greenoldman Jun 12 '11 at 7:41
up vote 6 down vote accepted

If you are using KDE's own builtin screensaver, I'm not sure... however, if you are using xscreensaver or are interested in using xscreensaver the following should help.

Using xscreensaver you can adjust the number of pixels that the mouse must move before deactivating the screensaver; not sure about completely disabling the mouse though.

If you are not already using xscreensaver within KDE you can follow these instructions to set it up: http://www.jwz.org/xscreensaver/man1.html#9.

Once you do that you can create a file in your home directory called .xscreensaver and in that file enter:

xscreensaver.pointerHysteresis: 20

with 20 being the number of pixels (10 is the default).

share|improve this answer
Thank you very much for such detailed answer. Sorry for long response, but I had to save some time to make all the setup. In my case there is probably a bug, I set the value to 100 (the maximum) and it takes only touching mouse to get xscreensaver turn off. – greenoldman Jul 3 '11 at 10:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.