Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i have done the following on my Asus WL-520gu

  1. Installed the dd-wrtv24-sp2 mini svn:13064
  2. Updated for usb support
  3. Installed optware package
  4. Activated the transmission client

but i keep getting a permission error for files. I think it is a user access thing.

How to resolve this issue? Is there any way to ignore user permissions on a drive?


i think it is due to the permissions of the user under which the transmission daemon is running. Can I change that user to root?

I know where but don't know how /etc/init.d/transmission.

enter image description here

share|improve this question
Does the user you are running as have write permissions to /mnt/data/torrents/downloads? – Faheem Mitha Jun 11 '11 at 6:36
I cannot parse the last sentence. What do you mean by "I know where but don't know how /etc/init.d/transmission"? – Faheem Mitha Jun 11 '11 at 7:54
up vote 4 down vote accepted

Don't change the daemon to run as root. Change the permissions on the folder where your daemon has to write so that it is allowed to do so.

Assuming it's running as user transmission, run something like this as root:

chown transmission /mnt/data/torrents/downloads
chmod u+rw /mnt/data/torrents/downloads
share|improve this answer
thanks @Mat for your response, i have tried it but results in same error. – Imran Naqvi Jun 11 '11 at 8:42
please edit your question to state what user the daemon is running as, and the permissions on your directory – Mat Jun 11 '11 at 8:43
ok i will as soon i get that info – Imran Naqvi Jun 11 '11 at 9:45
how did you manage to try what I posted without that info? – Mat Jun 11 '11 at 13:03
i am not a linux guru but i know some basics of chmod, so tried it earlier but it did not worked. – Imran Naqvi Jun 11 '11 at 17:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.