Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a laptop, which has a 500GB hard disk and with MBR partition, and I install my windows8.1 on it, but I left ~75G unused which I would like to use it for OpenSuse13.1. Now I have 2 USB, one is Gnome Live 13.1, another is standard DVD install ISO.

I tried to insert Gnome live 13.1 and no problems, it recognized my unused 75G partition, and recommend my Linux partition as below:

/dev/sda6 --> swap

/dev/sda7 --> /

/dev/sda8 --> /home

I cancelled this installation and try with DVD iso, and now I get an error when I try to use my 75G unused partition as below:

Your system states that it requires an EFI boot setup, since the selected disk does not contain a GPT disk label YaST will create a GPT label on this disk. You need to mark all partitions on this disk for removal.

I would like to keep my windows and create a dual boot system, but I am stuck here. anyone please give me some suggestions?

Error

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It sounds like you're either booting Windows 8.1 in legacy/BIOS/MBR mode (as opposed to EFI/GPT mode), or YaST is buggy and thinks that you have EFI booting enabled even though you don't. Another possibility is that your laptop's BIOS boots optical drives in EFI mode by default, causing YaST to load in EFI/GPT-only mode. Therefore, if there's a BIOS option in your laptop to turn off EFI booting, I suggest you set it. Another thing to try, is when you bring up the laptop's boot menu to select "boot from DVD-ROM", if there are 2 options "Boot from DVD - EFI" and "Boot from DVD - BIOS/legacy", pick "BIOS/legacy".

If you're really stuck, why don't you Google your laptop's exact model number with terms like "boot optical drive in BIOS/legacy mode" - this should hopefully point you in the right direction.

share|improve this answer
    
Thanks for the suggestion. My laptop BIOS did have an option to use legacy or EFI mode. I tried to choose legacy mode only and now everything looks fine. :) –  Coeus Wang Jul 26 at 13:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.