Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I ran the command fdisk -l to find out what my external drive is formatted to, I found out it's uses GPT partitions and the filesystem is HFS+.

When I try and create a new folder on the external drive I receive the following message:

chmod: changing permissions of 'file_name/': Read-only file system

If I run mount this is the output:

/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=dev)
/dev/sdc2 on /media/dev/andre backup type hfsplus (ro,nosuid,nodev,uhelper=udisks2)
/dev/sde2 on /media/dev/andre_clients type hfsplus (ro,nosuid,nodev,uhelper=udisks2)

So now I ran umount /dev/sde2 and unplugged the device then reconnected the device and ran the command dmesg | tail and got this information back:

[429154.613747] sd 14:0:0:0: [sde] Assuming drive cache: write through
[429154.615995] sd 14:0:0:0: [sde] Test WP failed, assume Write Enabled
[429154.616993] sd 14:0:0:0: [sde] Asking for cache data failed
[429154.616997] sd 14:0:0:0: [sde] Assuming drive cache: write through
[429154.669277]  sde: sde1 sde2
[429154.671369] sd 14:0:0:0: [sde] Test WP failed, assume Write Enabled
[429154.672742] sd 14:0:0:0: [sde] Asking for cache data failed
[429154.672747] sd 14:0:0:0: [sde] Assuming drive cache: write through
[429154.672751] sd 14:0:0:0: [sde] Attached SCSI disk
[429157.047244] hfsplus: write access to a journaled filesystem is not supported, use the force option at your own risk, mounting read-only.

Would it now be safe to run sudo mount -o remount,rw /dev/sde2 /media/dev/andre_clients without loosing any infomation?

share|improve this question
1  
Can you give us the output of mount ? Might be that your system is mounted read only, so you should mount it read+write. –  polym Jul 22 at 13:32
1  
that's the output of command mount? Can you please edit your question and put the output there? –  polym Jul 22 at 13:36
1  
One last thing: Please tell us, which device you are referring to. e.g. /dev/sdX or /media/dev/X etc. –  polym Jul 22 at 13:45
1  
This is the file I'm trying to change permissions on /dev/sde2 on /media/dev/andre_clients –  Code Jul 22 at 13:47
    
The fact that the disk uses GPT partitions is irrelevant. What matters is the filesystem type, which is HFS+. –  Gilles Jul 22 at 23:00

1 Answer 1

up vote 1 down vote accepted

Note:

It seems you need to mount a hfsplus as write/read, which is a bit problematic, because of it's journal function.

However, you can mount it as write/read as seen here and here.


The problem is that /dev/sde2 is mounted read only, according to the ro flag in the parentheses in the last line:

/dev/sde2 on /media/dev/andre_clients type hfsplus (ro,nosuid,nodev,uhelper=udisks2)

Therefore you can't change anything on this disk.

Remount it as read+write rw:

sudo mount -o remount,rw /partition/identifier /mount/point

In your case:

sudo mount -o remount,rw /dev/sde2 /media/dev/andre_clients

Before you do that, though, make sure you mount the right partition identifier by using dmesg | tail, e.g.:

[25341.272519] scsi 2:0:0:0: Direct-Access     [...]
[25341.273201] sd 2:0:0:0: Attached scsi generic sg1 type 0
[25341.284054] sd 2:0:0:0: [sde] Attached SCSI removable disk
              [...]
[25343.681773]  sde: sde2

The most recent sdX: sdXX line gives you a hint on which partition identifier (the sdXX one) your device connection is identified with.

You can also check which dev your device is connected to, by doing

ll /dev/disk/by-id/

This will give you all symbolic links of the device and it's partitions:

lrwxrwxrwx 1 root root   9 Jul 22 16:02 usb-manufacturername_*serialnumber* -> ../../sdb
lrwxrwxrwx 1 root root  10 Jul 22 16:02 usb-manufacturername_*serialnumber*-part1 -> ../../sdb1

share|improve this answer
    
Will this affect any information on the disk –  Code Jul 22 at 13:49
    
Only the information you change. e.g. creating a directory/file. –  polym Jul 22 at 13:53
    
iv updated my question to after i run dmesg | tail also when i say affect i mean will i loose any information stored in /dev/sde2 /media/dev/andre_clients –  Code Jul 22 at 13:57
1  
Ok looks like hfsplus has some problems being mounted with write. Can you execute the first and third command of this answer superuser.com/a/365270/333431 ? Do it after umount + dmesg|tail. –  polym Jul 22 at 14:23
1  
Thanks a million that last post just put the cherry on top you the bomb shot alot:D!!!!! –  Code Jul 22 at 14:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.