Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Recently, I installed Windows 8.1 and Linux Mint Debian Edition on a new laptop. Neither installs seemed to have any issues, and both operating systems run well. However, the only way I can switch between the two is by going to the boot menu and changing their boot priorities. Grub won't recognize windows 8, and windows boot manager throws an error if I add linux mint as an entry (using easybcd) and try to run it from there.

I've disabled both secure boot and fast boot.

My grub.cfg does seem to have an entry for windows 8, it just doesn't show up when I boot my computer. Here's what it looks like: http://pastebin.com/W98CdEA9

I've looked for solutions online already, but most people who have the same problem either didn't receive an answer at all, or received an answer specific to their case that doesn't seem to work for mine.

This is my first time dual booting, so I'm not sure what other relevant information I should include, so feel free to ask for anything needed.

share|improve this question
    
I'm not sure hence I will just add a comment look at my grub config pastebin.com/4yQ8ZBrG there is a section: # general configuration: timeout 5 default 0 color light-blue/black light-cyan/blue I don`t se it in your config so this might be a problem but I'm not familiar with UEFI so I'm not sure. –  vfbsilva Jul 22 at 2:48
    
From your Linux installation , did you run update-grub, and this is your recent grub.cfg file ? see also - superuser.com/questions/376470/how-to-reinstall-grub2-efi –  Rabin Jul 22 at 9:59
    
@Rabin I did run update-grub, and it didn't seem to help much. Would you recommend completely reinstalling grub? It still works, it just doesn't recognize windows, for whatever reason. –  kabb Jul 22 at 13:54
    
Windows 8 machines comes with UEFI, which i always disable and restore to the legacy BIOS. you can read the page i post earlier about grub-efi and see if it help you. Or you can disable UEFI and switch to the legacy BIOS and see if it helps. –  Rabin Jul 22 at 20:05
    
@Rabin Switching to legacy BIOS didn't work, so I tried following the steps in the link you gave and it worked! Thanks! –  kabb Jul 22 at 20:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.