Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to install Fedora on my computer with a netinstall, but it seems that the kernel doesn’t support my ethernet chip (Intel I218V). I tested Ubuntu 14.04 and Arch Linux and the ethernet chip worked (both have a newer kernel version).

So, how can I install Fedora with a newer kernel?

share|improve this question
The last update for the kernel in Fedora 20 was 3.15.5; I think the only thing you could do here is download that and modify the install image. – goldilocks Jul 19 '14 at 14:02
Also, Ubuntu and other distros have many kernel modules included - Fedora misses out some, some which you can get by installing 'kmod-staging' – Wilf Jul 19 '14 at 14:31
@goldilocks And how can i do this? – Yannick Ihmels Jul 19 '14 at 14:56
@Wilf And how I install the package without internet access? – Yannick Ihmels Jul 19 '14 at 14:57
what driver does it need? You should be able to find this on Arch/Ubuntu (even a Live install disk) by running lspci -v. – Wilf Jul 19 '14 at 18:01

It may be that the module you need is not included in the default kernel modules - you can likely solve this by installing the kmod-staging package.

  • First you would need to download the RPM of kmod-staging from here or somewhere else (e.g. here) - you will likely need to download dependencies such as staging-kmod-common . These packages need to match the kernel version (run uname -r)

  • Transfer them to the Fedora machine and install them with rpm -ivh FILES or yum install FILES.

share|improve this answer
So I have to install Fedora from a desktop install image, download the packages with another computer and install those on the Fedora machine? – Yannick Ihmels Jul 19 '14 at 21:30
@ynnckhmls - that would work, but I have just checked properly and the e1000e modules should be included in the kernel anyway - which kernel version it the freshly installed Fedora using? (use uname -r - it seems to be included in most recent Fedora kernels...). Have you tried loading it with sudo modprobe e1000e? And what shows in lspci -v? – Wilf Jul 19 '14 at 22:23
I have not installed Fedora yet. How can I load the e1000e module in Anaconda? – Yannick Ihmels Jul 19 '14 at 23:47

I think this is will be more trouble than it is worth for most people, but I'll outline some steps. Note I did not try this myself so there could be unforeseen complications (but I'm fairly certain it should work, if done properly). I have not gone into detail about accessing .rpm contents, building a kernel/initramfs, configuring grub, or creating a DVD (you'll need to produce a new copy) as these are all things better dealt with in individual questions (most of which probably already exist).

Rpmfind lists the most recent kernel .rpms here, but those do not include an initramfs, which you would need to make them boot. They do include a /lib/modules directory from which you could assemble one. A better idea might be to build a kernel for your system (using whatever distro) that does not require an initramfs, and use that.

The kernel used by the install disk is /isolinux/vmlinuz0. You can replace that or add an alternate grub entry in /EFI/BOOT/grub.cfg; if you are not using an initramfs, you don't want the entry to reference such, obviously.

If you go the custom kernel route, you may be able to get away without a /lib/modules/x.x.x although this could take some trial and error. The root filesystem is in /LiveOS/sqaushfs.img. You can mount that, e.g. mount -t squashfs squashfs.img /mnt/squash. Inside that there's only one file, /LiveOS/ext3fs.img, so after you mount squashfs.img you can mount -o loop /mnt/squash/LiveOS/ext3fs.img /mnt/img. There's a /lib/modules directory in there into which the stuff from the kernel rpm should go.

Of course, the image you've mounted from the DVD is read-only, so to create a new one you'd have to copy that, make your changes, then write it out to a new DVD.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.