Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

On quit, vim shows that:

".netrwhist" [Not edited] --No lines in buffer--

This process usually takes 2s. How to turn this thing off?

--- Update ---

I noticed that netrw is installed as system-wide. Use the code below to disable all of those plugins.

se nolpl
let x = &rtp
se rtp-=$VIMRUNTIME
ru! plugin/**/*.vim
let &rtp = x
unl x
share|improve this question
    
Thanks for following up on how to disable netrw. Rather than insert it in your question, it would be best to post this as an answer. –  Gilles Jun 6 '11 at 7:06

1 Answer 1

up vote 2 down vote accepted

It looks to be caused by the vim plugin netrw.vim.

You could remove the file and, if you do need that functionality, reinstall the plugin.

share|improve this answer
3  
To check that nothing is wrong with your installation, run vim --noplugin and the problem should go away. Then you know at least one of your plugins is bad (or doesn't play nice together). Disable/uninstall the faulty plugin (netrw.vim in this case) and everything should be OK. –  phunehehe Jun 5 '11 at 13:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.