Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I use Antegos (a distribution based on Arch Linux) and I installed GNOME in my system.

  • How can I disable GNOME running at system boot?
  • After booting without GNOME, how can I start it again?
share|improve this question

2 Answers 2

up vote 3 down vote accepted

What you mean by GNOME auto starting is, most likely, actually gdm (GNOME Display Manager) which provides the login screen. Just disable the service to stop it from autostarting. Arch uses systemd, so you want to do:

# systemctl disable gdm

Reboot and gdm won't automatically start. You can then manually start it whenever you want with:

# systemctl start gdm
share|improve this answer

If you want to disable completely the graphical session and boot into rescue mode edit the kernel line in grub at startup and add an s at the end of it. Alternatively you can also add systemd.unit=rescue to that line. See this thread

To start gnome from commandline it depends on the login manager. If you have gdm for example try sudo gdm.

If it's just that you installed gnome and want to switch to a previous desktop manager, look for a menu named "sessions" or something like it at the login screen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.