Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have Fedora 15, and Gnome 3. But i would like to update to the latest version of Gnome 3 (where i have 3.0.1 always). For some error reason i must need to upgrade to Gnome 3.0.3

How do we update Fedora for a specific application or group applications to latest version?

Thanks

share|improve this question

migrated from stackoverflow.com Jun 2 '11 at 12:34

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 2 down vote accepted

You should try:

yum install @group-name

yum groupinstall group1 [group2] ...

Or you should try running the graphical package manager and update the entire group.

EDIT1

Currently GNOME3.0.2 is the latest. The GNOME3.0.2 is still not available from the fedora repositories. You need to manually compile the binaries to get it.

EDIT2

Got from #fedora freenode channel: Check this : http://osdir.com/ml/fedora-announce/2011-05/msg01634.html

yum update gnome-shell

share|improve this answer
    
@phoxis: I tried that but still i get Gnome 3.0.1 instead of latest 3.0.3 yum groupupdate "GNOME Desktop Environment" "Development Tools" "Server Configuration Tools" "Hardware Support" "Sound and Video" "Graphical Internet" "Fonts" "Games and Entertainment" "Printing Software" "Administration Tools" "Office/Productivity" "System Tools" --skip-broken –  89899.3K Jun 2 '11 at 9:38
    
GNOME3.0.3 is not released yet. check the answer update. –  phoxis Jun 2 '11 at 9:44
    
@phoxis: still no luck. # yum update gnome-shell Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit Setting up Update Process No Packages marked for Update –  89899.3K Jun 2 '11 at 11:08
    
as you see, it is not still available from the fedora repositories. If you want it then either wait for it to come into the fedora15 repos, or compile from source. –  phoxis Jun 2 '11 at 11:09
    
Compile from the source is always problem with Fedora. I will give a try if not then i will change my desktop from Gnome 3 to Xfce. Because Gnome 3 is not working for many issues. –  89899.3K Jun 2 '11 at 11:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.