Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'd like to set the terminal title to user@host so I can easily tell which machine I'm connected to from the window title. Is there a way to do this from SSH or from GNOME Terminal?

share|improve this question

2 Answers 2

up vote 16 down vote accepted

Yes. Here's an example for bash using PS1 that should be distro-agnostic:

Specifically, the escape sequence \[\e]0; __SOME_STUFF_HERE__ \a\] is of interest. I've edited this to be set in a separate variable for more clarity.

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
        # We have color support; assume it's compliant with Ecma-48
        # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
        # a case would tend to support setf rather than setaf.)
        color_prompt=yes
    else
        color_prompt=
    fi
fi

TITLEBAR='\[\e]0;\u@\h\a\]'
# Same thing.. but with octal ASCII escape chars
#TITLEBAR='\[\033]2;\u@\h\007\]'

if [ "$color_prompt" = yes ]; then
    PS1="${TITLEBAR}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\W\[\033[00m\]\$ "
else
    PS1="${TITLEBAR}\u@\h:\W\$ "
fi
unset color_prompt force_color_prompt

Also note that there can be many ways of setting an xterm's title, depending on which terminal program you are using, and which shell. For example, if you're using KDE's Konsole, you can override the title setting by going to Settings->Configure Profiles->Edit Profile->Tabs and setting the Tab title format and Remote tab title format settings.

Konsole titlebar settings dialog

Additionally, you may want to check out:

share|improve this answer
    
So do I need to set this on all of the servers I am connecting to or on my own local machine? –  Naftuli Tzvi Kay May 31 '11 at 21:11
    
@TKKocheran: You need to do this on every machine where you're running a shell. If you only want to do it for remote logins, put \h in that prompt only if $SSH_CLIENT is non-empty. –  Gilles May 31 '11 at 21:19
    
@TK : Yes, you will need to set this on all the servers you connect to. The PS1 variable is local to your current shell (even on a remote host), not the terminal program (ie: gnome-terminal). –  TrinitronX May 31 '11 at 21:20
    
I assume that this will apply differently on servers not running Debian. Can you edit your answer to provide for servers running, let's say, Fedora/Red Hat derivatives? –  Naftuli Tzvi Kay May 31 '11 at 21:29
1  
@TK : I tested this using SSH to various hosts from an Ubuntu 11.04 machine... So the title bar was set correctly there... If it doesn't work, try adding this sequence to the front: \[\e]2;\u@\h\a. (Also edited my response with that info) –  TrinitronX May 31 '11 at 22:14

Here's a version of the SSH bash script that I use which sets the remote server's title and command prompt without making any changes to the remote server.

my_ssh.sh:

#!/bin/bash
SETTP='MY_PROMPT="$HOSTNAME:$PWD\$ "'
SETTP="$SETTP;"'MY_TITLE="\[\e]0;$HOSTNAME:$PWD\a\]"'
SETTP="$SETTP;"'PS1="$MY_TITLE$MY_PROMPT"'
ssh -t $1@$2 "export PROMPT_COMMAND='eval '\\''$SETTP'\\'; bash --login"

You can invoke it by calling ./my_ssh.sh username hostname

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.