Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I would like to disable automatic wifi negotiation on my 1000HE eeepc. WiFi Chipset is a ralink2860sta. I am using the non-free module and everything is working as intended except it tends to pick up first available access point everytime I boot up. I have various ways to configure wlan0 in /etc/network/interfaces but whatever I set up I would like to prevent negotiation or essid setting up.

share|improve this question
add comment

1 Answer

I don't know if there is a "Debian" way to do it but there is the /etc/wpa_supplicant/wpa_supplicant.conf file (maybe /etc/wpa_supplicant.conf) where you can specify which networks you want to use. For example:

network={
    id_str="stribnet"
    ssid="stribnet"
    priority=10
    proto=RSN
    key_mgmt=WPA-PSK
    group=CCMP
    pairwise=CCMP
    # I no longer use this key. It was last year's I think.
    #psk="/5w7Pb1K3X+8olncu6tQAICqm9cit6NAvqF86jOofWIDV6y/I+QN93SZV6z6"
    psk=91d55b029c84d8300dfb14930e345295d493ddf3c52d710288403e77bc5183a0
}

network={
    id_str="qb402"
    ssid="B402"
    priority=2
    key_mgmt=NONE
}

The priority options determines which network you prefer. This will try to connect to stribnet, then B402. If you want the old behaviour you can add this:

network={
    id_str="default"
    key_mgmt=NONE
    priority=-1
}
share|improve this answer
    
Thank you, I was able to fine-tune my setup with your help. Overtime, as the number of different AP I needed to connect to increased, I decided to use wicd to save me the hassle. –  John Christopher May 17 '12 at 20:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.