Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running on FreeBSD 8.2, I have a device that will run NanoBSD 7.4. To install packages for nanobsd, you put them in /usr/src/tools/tools/nanobsd/Pkg, and uncomment the line in your config.

I need to get JamVM installed on the NanoBSD, this depends on diablo-jre. When nanobsd.sh tries to install the diablo package, the log _.cust.cust_pkg is spammed with Do you accept the license [yes/no].

I need to unpack the diablo package and edit +INSTALL, then repack it. How can I do this?

Same question but on superuser: http://superuser.com/questions/290494/update-diablo-jre-freebsd7-i386-1-6-0-07-02-tbz-install-do-you-accept-when-ins

share|improve this question
    
Do not post the same questions to multiple sites. Pick one, and delete the version on the other site (you may need to flag for a moderator to do it if you don't have enough reputation). In the future, if you want to move a question to a different site, flag for a moderator to migrate it. –  Gilles May 31 '11 at 10:10
    
@Gilles Thank you, I flagged it on SU. –  CS01 May 31 '11 at 11:01

1 Answer 1

up vote 1 down vote accepted

Unpack .tbz with tar xf to empty directory, edit +INSTALL and pack it again with tar cjf ../new_package.tbz *. FreeBSD's binary package is just bzipped tar archive, nothing special.

share|improve this answer
    
Hi, tried the command, but I get this error: tar xf diablo-jre-freebsd7.i386.1.6.0.07.02_12.tbz diablo-jre1.6.0/man/ja/man1/: Cannot extract through symlink diablo-jre1.6.0/man/ja diablo-jre1.6.0/man/ja/man1/unpack200.1: Cannot extract through symlink diablo-jre1.6.0/man/ja diablo-jre1.6.0/man/ja/man1/tnameserv.1: Cannot extract through symlink diablo-jre1.6.0/man/ja diablo-jre1.6.0/man/ja/man1/servertool.1: (snip) tar: Error exit delayed from previous errors. –  CS01 Jun 3 '11 at 10:52
    
did you extracted it to empty directory? I've tried tar xf diablo-jre-1.6.0.07.02_13.tbz on package created with pkg_create -b and it work just fine. Can you show full tar output? –  gelraen Jun 3 '11 at 13:05
    
Here you go pastebin.com/yyaaBni1 –  CS01 Jun 6 '11 at 7:45
    
PS: [root@nano /usr/src/tools/tools/nanobsd/diablo]# md5 diablo-jre-freebsd7.i386.1.6.0.07.02_12.tbz MD5 (diablo-jre-freebsd7.i386.1.6.0.07.02_12.tbz) = d6336d91c4731ef68f70f3ca063e34e9 –  CS01 Jun 6 '11 at 7:46
    
I'm using this: freebsdfoundation.org/cgi-bin/… via freebsdfoundation.org/downloads/java.shtml - just to be more verbose... –  CS01 Jun 6 '11 at 7:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.