Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an issue with Fedora 15's available memory. The laptop it is installed on has 4GB of SDRAM, but Fedora only sees 2GB.

[njozwiak@calvin xpmc6720]$ free -m
             total       used       free     shared    buffers     cached
Mem:          2193       1994        198          0         59       1405
-/+ buffers/cache:        529       1663
Swap:         4255          0       4255

I realize F15 is a 32-bit OS, but I should still be able to access more than 2193MB. Any ideas?

[njozwiak@calvin xpmc6720]$ uname -a
Linux calvin #1 SMP Sun May 15 17:57:13 UTC 2011 i686 i686 i386 GNU/Linux
share|improve this question
up vote 1 down vote accepted

What kernel are you using? The kernel needs to have BIGMEM support.

Fedora 15 offers BIGMEM support in PAE kernels. So install (for example) the Fedora 15 2.6.38 PAE kernel.

share|improve this answer
[njozwiak@calvin xpmc6720]$ uname -a Linux calvin #1 SMP Sun May 15 17:57:13 UTC 2011 i686 i686 i386 GNU/Linux. How do I determine if my kernel supports bigmem? – linsek May 30 '11 at 17:04
@njozwiak: check your kernel config for options containing the string CONFIG_HIGHMEM. Some of these options need to be set to yes. Paste if you are not sure. Googling suggests that Fedora has bigmem support in PAE kernels. Search for a linux kernel with PAE in the string. – Faheem Mitha May 30 '11 at 17:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.