Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Fedora 20 using the liveOS.

While taking the updates I am getting the following result:

[root@localhost bioinfo]# yum update
Loaded plugins: langpacks, refresh-packagekit
Error: Cannot retrieve metalink for repository: fedora/20/i386. Please verify its path and try again

How do I fix this error?

share|improve this question

This problem seems to come using secure https. Go in /etc/yum.repository.d and replace all https with http in different .repo files.

share|improve this answer
fwiw, confirmed on fedora 17 – JustJeff Nov 3 '14 at 13:08
-- confirmed with Fedora 15 – polerto Feb 17 '15 at 21:18
Weird as https is the default... Date and time correct (lol and not on a lenovo laptop). – Kevin Feb 26 '15 at 0:38
This worked for me: ls /etc/yum.repository.d/*.repo | xargs sed -i 's/https:/http:/g' – Joe Heyming Aug 22 '15 at 23:52

It is possible that your ca-certificates are in need of an update or corrupt.


# yum update ca-certificates

If that doesn't offer to update the package, then reinstall:

# yum reinstall ca-certificates

If that fails, it could be that the server you are connected to has updated it's certificates (maybe from a new vendor) and that the certificate chain and/or root certificate isn't in the ca-certificates package yet. The certificates in this package are chosen by the Mozilla Foundation.

If this is the case, then @Saturn's answer should hopefully help.

share|improve this answer

I modded up the other two answers, they're both helpful ... GarethTheRed has got the real answer. I ran into the same problem after doing a version upgrade and my ca-certificates was out of date.

However, to be able to update ca-certificates, you first have to be able to actually use yum. I suggest:

  1. Go to /etc/yum.repos.d
  2. Edit fedora.repo and fedora-updates.repo. In both files, uncomment the baseurl line that uses plain http and comment out the metalink url that uses https.
  3. Do yum update ca-certificates or yum reinstall ca-certificates (as in Gareth's answer).
  4. Undo the changes from step 2 so that you will go back to using both https and the metalink redirect.
  5. All done, test yum and it should work again.
share|improve this answer

Current version of Fedora is 23, there are still updates for 22. Fedora 20 is long, long past end of life. No wonder there are no updates anymore.

share|improve this answer

inaddition to above mensioned , we have to do edit the web links which are not present. like replace the lines in /etc/yum.repo.d/* with 'baseurl=http://download.fedora.redhat.com/pub/fedora/linux' with 'baseurl=http://archives.fedoraproject.org/pub/archive/fedora/linux' It worked for me. Try it out. LOL....

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.