Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried setting up git as shown in Github's help page, on Arch linux but there seems to be some problem with the SSH keys. It gives this error-

Permission denied (publickey).

This problem is documented in the troubleshooting page but I when I tried the procedure shown there, it didn't really solve the problem. How can I solve this problem?

share|improve this question

Make sure that you have set the correct permissions on your ~/.ssh folder.

$ chmod go-w ~/.ssh

See: https://wiki.archlinux.org/index.php/Using_SSH_Keys

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.