Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

We have a LG-R590 laptop and an AirTies 5343 WLAN router at home. When the router broadcasts the SSID of the wireless home network I cannot connect to the network automatically, I have to connect to the network as if its SSID were hidden.

When I set the router to hide the SSID of the home network the wireless network browser in Mint MATE is able to see and connect to the network. However, in this case the SSID is hidden in Windows as expected and leads to undesired effort to get connected to the internet on other computers, and I am concerned about this since my parents are not that much tech-savvy. I have provided a screenshot of the modem settings (saved) when the computer is able to locate and connect to the network on Linux Mint 16 MATE. How can I restore default behaviour on this computer so that it sees and is able to connect to the network when SSID is broadcasted?

Details:

Linux Mint Mate 16 32-bit

LG R590 Notebook

Output of lspci

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)

03:00.0 Ethernet controller: Qualcomm Atheros AR8131 Gigabit Ethernet (rev c0)

enter image description here

Thanks in advance

share|improve this question
    
I don't think it's a wise thing to publish your WLAN password here. You certainly should change it as soon as possible now. –  celtschk Jun 21 at 16:36
    
Consider the fact that everything ELSE connects just fine when the SSID is NOT hidden... the problem is your Mint installation. Figure out what's non-standard there, and you'll solve your problem. It's not the router, it's not mom's computer, and it's not your parents. –  lornix Jun 21 at 19:52
    
@lornix Well what may have went wrong in your opinion? –  Vesnog Jun 21 at 20:42
    
@celtschk I thought it would not pose any hazard since the probability that someone in the vicinity of our network would read it is relatively low anyhow I can change it. –  Vesnog Jun 21 at 20:44
    
You haven't indicated what desktop you're using (if any), what settings you've selected, what version you're using, and whether it's sunny outside or not. something is different about your particular Mint setup which is causing it to operate slightly different. But you're trying to say it's the router. Which it cannot be, since many other standard devices can access it with standard setups. Perhaps it is the router, but experience shows that it's very unlikely and would be inappropriate to start there. Not trying to be mean. –  lornix Jun 21 at 20:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.