Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've got problems with installing PHP 5.5.13 (last stable build) on a CentOS 6.5 (64 bit) machine, through yum. Can somebody guide me through this a little bit?

It is not a part of the CentOS, EPEL or REMI repos as far as I can see. I get 5.4.29 with either of those repositories.

share|improve this question
add comment

2 Answers 2

up vote 4 down vote accepted

With distros such as RHEL and CentOS, they typically have a 7-10 year lifetime, it's difficult to keep them up to date with the latest versions of things. Your only options are to:

  1. go without it
  2. build it from source yourself
  3. use a 3rd party repository that provides alternative packages

I typically go with #3. You can use this repo to install 5.5:

To install the repo:

$ sudo rpm -Uvh http://mirror.webtatic.com/yum/el6/latest.rpm

To install the packages:

$ sudo yum install php55w php55w-opcache

This is one of many 3rd party repos that provide packages in this manner. Always make sure that you're OK with using these repos, prior to just jumping in and using them. Some are better than others, but I've never run into an issue with using their builds of packages.

Using remi repo

This repo does provide the 5.5 packages of PHP, you just need to know how to tell it that that's what you want.

Setting up repo, if not already

$ sudo wget http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
$ sudo wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
$ sudo rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm

This will upgrade PHP from 5.3.3 to PHP 5.4.24 (15. January 2014).

$ sudo yum –enablerepo=remi update -y

If you want the newest PHP, version 5.5.x you must run the following command:

$ sudo yum –enablerepo=remi,remi-php55 update -y

References

share|improve this answer
    
I have tried $ sudo yum –enablerepo=remi,remi-php55 update -y, but it want me to install 5.4.29. Does not make much sense. I have tried a lot of things to make it work from remi. –  Adionditsak Jun 19 at 14:04
    
@Adionditsak - take the remi, out of the list, it's probably trying to update your base install of php. –  slm Jun 19 at 15:29
add comment

You won't typically find the latest releases of software in a distro's package manager. Unless a package has critical security patches, the version that is available via the package manager was the must current version when the release went into a testing freeze.

Freeze - During the freeze period, development of the Testing distribution is blocked; no more automatic updates are allowed. Only the Release Managers are then authorized to change packages, according to their own criteria. The purpose is to prevent the appearance of new bugs by introducing new versions; only thoroughly examined updates are authorized when they correct significant bugs.

You'll have to either build php from source, create you own rpm/repo or find a third party that has already built an rpm and is making it available

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.