Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My laptop is both using a wired connexion and a wireless one. I installed dhcps3-server, after that I guessed that there is no wireless network displayed. What can I do to see available wireless networks (I have my own wireless network that is not displayed).

I had the same problem yesterday when I installed dhcp3-server. I checked for solutions on internet but in vain. So I had to reinstall Ubuntu again. I do not want to reinstall it again each time i need dhcp3-server or any other tool.

When I run nm-tool, I got this (for the wireless part):

NetworkManager Tool

State: connected

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             unmanaged
  Default:           no
  HW Address:        D8:AF:9A:B7:DA:D9


  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 

My wireless device is not disabled by hardware. I run rfkill list and I got this:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

My Ubuntu can see my wireless device also. I run lshw -C network and I got this (for the wireless part, and you can also see that the driver for wireless adpater is installed):

       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:25:00.0
       logical name: wlan0
       version: 01
       serial: d0:df:9a:5b:da:4a
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=2.6.38-8-generic firmware=N/A ip= latency=0 multicast=yes wireless=IEEE 802.11bgn
       resources: irq:19 memory:d4600000-d460ffff

Also, my wireless PCI device is shown (but its driver not working ?) when I run : lspci -nn:

 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)

I run iwconfig and I got these information:

lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=17 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

How can I resolve this problem (displaying back the wirless networks )?
Note that my wired connexion works well.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.