Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install PgSql in the system with following specs:

Distributor ID: Debian
Description:    Debian GNU/Linux 7.1 
Release:    7.1

x86_64

But I am getting an error like this

   The following packages have unmet dependencies:
     postgresql-9.3 : Depends: libc6 (>= 2.15) but 2.13-38+deb7u1 is to be installed

How can I install the missing pakage?

I tried apt-get install libc6=2.13-38+deb7u1 and its showing libc6 is already the newest version. but still the issue persist.

share|improve this question

migrated from askubuntu.com Jun 18 at 14:47

This question came from our site for Ubuntu users and developers.

    
what is the output of apt-cache madison libc6 –  123456 Jun 18 at 14:03
    
I suggest you update your system first. –  schaiba Jun 18 at 14:54
1  
You've got messed up package sources. Post the content of the following files: /etc/apt/sources.list, any file in /etc/apt/sources.list.d, and /etc/apt/preferences. Also, make sure you run apt-get update after modifying any of these files. –  Gilles Jun 18 at 22:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.