Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

In my office, I have AT&T Uverse. The router is a 2wire 3600HGV. The WiFI is provided by a Cisco Linksys E1000 that is plugged in the 2wire device.

With my notebook running Ubuntu 12.04 LTS 64bit, I have both the eth0 (192.168.1.66/24) and eth1 (10.0.0.124/24). Both are managed via DHCP. Whether I have an Ethernet cable plugged in or not, DNS works.

I just got a used netbook. I installed CentOS 6.5 on it using a DVD with a minimal desktop. By default the NetworkManager manages the wlan0. DNS works. I manually configured a static IP for the wired interface. As soon as I enabled the interface, DNS stops working. I dug around the system and searched the Internet looking for answers but haven't found a clue.

Would be appreciative for any hints.

share|improve this question
1  
If you configured a static IP, did you also set the DNS server in the static configuration? And did you use NetworkManager for the static configuration or edit config files directly? –  Dubu Jun 18 at 6:32
    
The following is what I have in /etc/sysconfig/network-scripts/ifcfg-eth0 DEVICE="eth0" HWADDR=E8:9A:8F:17:70:42 TYPE="Ethernet" ONBOOT=yes NM_CONTROLLED="no" BOOTPROTO=static IPADDR=192.168.1.4 PREFIX=24 IPV4_FAILURE_FATAL=no IPV6INIT=no NAME="System eth0" –  user72869 Jun 18 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.